Support » Plugin: UpdraftPlus WordPress Backup Plugin » Google Drive Fail To Upload

  • Resolved Richard Bland

    (@blandydoes)


    Hello,

    I have multiple clients using the free version of UpDraft and they were backing up to my Google Drive. Just recently ALL of these have been failing to upload to Google Drive giving a PHP error.

    Fatal error: Uncaught TypeError: Argument 1 passed to NF_FU_VENDOR\Google_Client::__construct() must be of the type array, object given, called in ****************/wp-content/plugins/updraftplus/methods/googledrive.php on line 825

    Has anyone else had this happen using Google Drive as the storage?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author David Anderson

    (@davidanderson)

    Hi,

    This is a bug in the plugin Ninja Forms Uploads; it loads its own version of the Google SDK into memory in all contexts (including, when UD wants to run a backup). As a result, UpdraftPlus cannot load its own version.

    David

    Richard Bland

    (@blandydoes)

    Thank you David. Is there a known workaround for those sites that need to use the file upload?

    I actually disabled it on my own site as was not using it but Updraft still fails to run.

    Plugin Author David Anderson

    (@davidanderson)

    Hi Richard,

    If you have a copy of Ninja Forms Uploads, you can send it to us so that we can investigate possibilities of a work around.

    David

    Richard Bland

    (@blandydoes)

    Sorry David, forgive my ignorance – when you say have a copy do you mean the logs? Is there somewhere I can send this to you?

    Plugin Author David Anderson

    (@davidanderson)

    A copy of the plugin, so that we can inspect its source and see if there is a way to prevent it doing what it should not. Though, before doing that, it’d be best to report it to their support to see if they can fix it. i.e. Change it so that it only loads the Google SDK when it is about to contact Google, not in every context.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.