Support » Plugin: UpdraftPlus WordPress Backup Plugin » Google Drive doesn’t authenticate but Updraft partially thinks it does

  • Resolved qaws

    (@qaws)


    I’m using Google Drive as the backup target.

    My backup gets created locally but doesn’t upload to my Google Drive, even after I allow the access. In my log I get:

    0633.272 (2) Requesting upload of the files that have not yet been successfully uploaded (11)
    0633.274 (2) Cloud backup selection (1/1): googledrive with instance (1/1) (last)
    0633.274 (2) Beginning dispatch of backup to remote (googledrive) (instance identifier s-identifier)
    0633.322 (2) Google Drive: ERROR: Have not yet obtained an access token from Google (has the user authorised?)
    0633.323 (2) An error condition has occurred for the first time during this job

    If I go through the Google Drive setup, I Allow the access to Updraft. This takes me to an orange Updraft page with a “complete set-up” button, which I click. This takes me to my wpadmin page, and I have 2 messages on here from Updraft:
    Success: you have authenticated your Google Drive account.
    and
    Google Drive: Have not yet obtained an access token from Google – you need to authorise or re-authorise your connection to Google Drive.

    The “Authenticate with Google” section of the Settings says:
    (You appear to be already authenticated, though you can authenticate again to refresh your access if you’ve had a problem).

    and if I click “save” and then the “After you have saved your settings (by clicking ‘Save Changes’ below), then come back here once and follow this link to complete authentication with Google Drive.” link, it just takes me through the process to allow the access again, and I get the same results.

    It seems to formulate the URL correctly to return to my wpadmin:
    https://mysite/wp-admin/options-general.php?action=updraftmethod-googledrive-auth&state=success%3As-identifier&access_token=abigaccesstoken&user_id=abigrandomstring%3D%3D

    and this clearly has the access token in it. But it doesn’t seem to want to save this anywhere.

    Note that I’ve also clicked the link to remove the settings so I can start again, and I’ve gone through the setup again, but the behaviour is exactly the same.

    Any help appreciated.

    • This topic was modified 1 year, 10 months ago by qaws.
    • This topic was modified 1 year, 10 months ago by qaws.
Viewing 10 replies - 1 through 10 (of 10 total)
  • Thread Starter qaws

    (@qaws)

    Plugin Contributor bcrodua

    (@bcrodua)

    Hi,

    Do you have any caching or security plugin installed on your site? Can you also try to temporarily deactivate?

    Could you also try if the same issue happens if you use other remote storage such as Dropbox?

    Regards,
    Bryle

    Thread Starter qaws

    (@qaws)

    I’ve deactivated WP Super Cache and tried again but get the same result. I won’t be deactivating Wordfence because this is a live site.

    I also have some hardening rules in one of my WordPress ini files, I forget which one, which could be affecting it? But I don’t want to remove these because this is a live site.

    I’ve checked my Google Drive settings and it shows that Updraft is authorised to perform some actions, it’s just the part where Updraft needs to save the authentication token into its own settings that isn’t happening.

    Thread Starter qaws

    (@qaws)

    I have 2 sets of extra things in my .htaccess file. One rewrites the URL to http from https if it matches “/api/” in the path, and I have a hardening rule:

    # Security headers from sucuri.com
    <IfModule mod_headers.c>
      Header set X-XSS-Protection "1; mode=block"
      Header always append X-Frame-Options SAMEORIGIN
      Header set X-Content-Type-Options nosniff
    </IfModule>

    I’ve created a dropbox account and it seemed to work: the “Success” message in the Updraft settings page after I authenticated included my dropbox account name and a printout of how much storage was in use, which implies it must have connected successfully. I’ll let you know if this works but I’ll still need to get Google Drive working because Google Apps is our strategic solution.

    Thread Starter qaws

    (@qaws)

    THe backup to Dropbox completed successfully, so it’s something to do with Google Drive setup that still needs fixing.

    Please let me know what else I can try.

    Many thanks.

    Thread Starter qaws

    (@qaws)

    I removed the security headers mentioned in a previous comment and tried again but there was no differrence.

    Thread Starter qaws

    (@qaws)

    I’ve signed out of all my Google accounts in the browser and signed in only to the one which I’ve specified for backups, but there’s no difference. I’ve also tried doing the whole thing in Chrome’s Incognito Mode and still no difference. ANd, I tried wiping all the settings in Expert mode and that also made no difference. My IP is not blocked on your authentication server.

    • This reply was modified 1 year, 10 months ago by qaws.
    Thread Starter qaws

    (@qaws)

    The last successful backup was May 27 2019, but I didn’t notice this until the other day when I raised the support ticket. I assumed it had stopped backing up because the remote storage was full, but I’ve loggd into the original Google Drive just now and it’s only 11.1GB full out of 15GB, and my backups are 371MB, so there is enough space. It used to do a weekly backup without issue.

    I’ve tried reauthenticating using the old Drive account but I still get the same error.

    Thread Starter qaws

    (@qaws)

    I wiped my settings and then followed these instructions to set up my own Google Drive app: this worked and my backup is now saved in Google Drive successfully.

    Putting this fix in here in case it helps someone else:

    I just switched to Google Drive from Dropbox and all but the last two worked fine. Those last two kept using Dropbox. I did the Wipe for one and that fixed it. One the second one, I noticed that next to the Send to Remote Storage, you can click the (…) and a dropdown appears. Dropbox was checked so I checked Google Drive and boom, it works!

    Screenshot https://ibb.co/dm29qmT

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Google Drive doesn’t authenticate but Updraft partially thinks it does’ is closed to new replies.