WordPress.org

Forums

NextScripts: Social Networks Auto-Poster
[resolved] Google+ does no longer show featured image at all (9 posts)

  1. mdidesign
    Member
    Posted 1 year ago #

    Hi,

    the last months Google+ did SOMETIMES grab the correct image to show by auto-posting. But now Google+ does no longer grab an image at all - all auto postings just show the text - no image at all. No matter at what time you are posting the auto-post... 10 minutes delay, 20 minutes delay or manually after some time: No picture is shown any more. Whats wrong there?

    https://wordpress.org/plugins/social-networks-auto-poster-facebook-twitter-g/

  2. NextScripts
    Member
    Plugin Author

    Posted 1 year ago #

    Please check your og:image metatag. Google takes it's images only from it.

  3. mdidesign
    Member
    Posted 1 year ago #

    Depending on the post there are multiple og:image tags. But the first one is always the featured image. But still Google does no longer take this picture, just one of the others.

  4. NextScripts
    Member
    Plugin Author

    Posted 1 year ago #

    Could you please have just one correct metatag. Nobody can control what google will do if you have several og:image tags

  5. mdidesign
    Member
    Posted 1 year ago #

    But those tags are important for metadata etc. So that all pictures can be found, this is automatically set.

  6. NextScripts
    Member
    Plugin Author

    Posted 1 year ago #

    Then you need to decide what is more important correct image for G+ or whatever you mean...

  7. mdidesign
    Member
    Posted 1 year ago #

    I tried it out. Now there is just one og:image tag left - the featured image. I reloaded everything, have put it into the Google Structured Data Test Tool... and posted it on Google+ again: Still Google does NOT use the featured image. It takes just one from the content.

  8. NextScripts
    Member
    Plugin Author

    Posted 1 year ago #

    OK. Let me explain something.

    In case of Google+ "Link" post our plugin does NOTHING in terms of image or description of the link. Google+ simply does not have ANY way to set or change them. Plugin gives Google+ the LINK and only the LINK and tells it "attach this link to this post message". That's it. Nothing more, nothing less.

    Google+ somewhere internally analyzes that link and attaches it to the post message with the title and image it thinks should be there.

    There is no way to do anything else. It's totally up to google+ what image to get. In most cases it takes the image from og:image tag. Sometimes it thinks that og:image is not appropriate (bad size, bad quality, guess your own reason) and takes some other image.

    There is nothing can be done from our side.

  9. mdidesign
    Member
    Posted 1 year ago #

    Thanks you very much for this explanation!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • NextScripts: Social Networks Auto-Poster
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.