WordPress.org

Forums

[resolved] Google couldnt index my site (8 posts)

  1. ade9ja
    Member
    Posted 4 years ago #

    Good day house, i just make a search of my url on google.com and i notice from the result that none of the link lead to my site url, please help, just installed the blog 2 months ago and have posted a total of 27 articles, how do i get my site index by google and other big search engine.
    Do i have to do meta work for the robot/crawler index my site?

  2. Joseph
    Member
    Posted 4 years ago #

    First of all, check the following:
    1. Make sure that the privacy setting in Settings > Privacy is not blocking any search engines.
    2. Make sure there isn't a robot noindex meta tag in your HTML head.
    3. Check if you have a robot.txt that's blocking Googlebot.

    Once you've done that, there are a two things you can do to help Google index your pages if you haven't done it already:
    1. Create a sitemap with the Google XML Sitemaps plugin.
    2. Use Google Webmaster Tools.

  3. ade9ja
    Member
    Posted 4 years ago #

    @ josehph thanx for the info and tips but how do i now create a sitemap, though have installed and activated the sitemap xml plugin from wordpress.

  4. ade9ja
    Member
    Posted 4 years ago #

    thanx again, i just successful added the google meta tag from their webamaster tools to my site, so let wait 24 hrs for the index.

  5. James Huff
    Volunteer Moderator
    Posted 4 years ago #

    Once you have installed and activated the sitemap plugin, go to Settings/XML Sitemaps in your Dashboard to setup the plugin and generate your sitemap.

  6. ade9ja
    Member
    Posted 4 years ago #

    thanx very much for the tutorial.

  7. Joseph
    Member
    Posted 4 years ago #

    You're Welcome.

    Can you please put this as resolved? Thanks.

  8. James Huff
    Volunteer Moderator
    Posted 4 years ago #

    You're welcome!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.