WordPress.org

Forums

Easy FancyBox
[resolved] Google Chrome, Adobe Flash, & Easy FancyBox (5 posts)

  1. mintertweed
    Member
    Posted 2 years ago #

    I have run into a bit of a problem. I want to show some of my Adobe Flash games in Easy FancyBox. So, I uploaded my *.SWF to my WordPress Media and placed it twice on the appropriate page (one version using Easy FancyBox and the other one without Easy FancyBox). I click on the link using Easy FancyBox and it opens just fine. Everything is animating properly. My problem is: in Google Chrome, I am unable to move my game character. He just sits there. I opened the same page in Mozilla Firefox and I am able to move my character. So, it is definitely the browser. But I went a step further. I then opened the *.SWF without Easy FancyBox in Google Chrome and my game character moves perfectly fine. So, conclusion: something is happening with Easy FancyBox in Google Chrome. Have there been any similar reports for those who use Google Chrome? And how can I fix this? To view my example, you may visit here. You must view it with Google Chrome to see the error. If you view it in Mozilla Firefox, everything works fine. Thank you in advance!

    http://wordpress.org/extend/plugins/easy-fancybox/

  2. mintertweed
    Member
    Posted 2 years ago #

    Also, in Google Chrome, when you click on a *.PDF to view it in Easy FancyBox, it skips to the second page, instead of displaying the first. This is not so horrible because whomever is viewing the document can simply scroll up, but my previous post is nearly a deal-breaker and I love using Easy FancyBox. Please respond.

  3. Sue
    Member
    Posted 2 years ago #

    No solutions, but I came here to report the same issue in Chrome while viewing a pdf - it displays page 2 of 3, or it displays the bottom of the page, rather than the top when the display windwo opens.

    True, the user can scroll to the top, but why is it doing this, and why only in Chrome? It displays the first page / beginning of the document in Firefox and in IE, while in Chrome it jumps to somewhere in the middle of the document when the window is opened.

    You can view the behavior on this page of a site currently in development, due to launch next week, so a solution would be most helpful! Click the Weekly Bulletin link...

    http://vbc.larennetworks.net/events/bulletin/

    Thanks for any help!

  4. RavanH
    Member
    Plugin Author

    Posted 2 years ago #

    Funny things, these browser plugins. In both cases, Google Chrome uses a custom on instead of the regular ones as all other browsers do... Not even Chromium, the open source version of Chrome, shows this issue.

    Anyway, for both cases (PDF and Flash) I propose to test the following:

    Disable PDF and SWF support in the FancyBox settings and enable iFrame support. Then change the links to these files (use the HTML tab) so they have a class="fancybox-iframe" attribute.

    Then we try again in Chrome :)

  5. mintertweed
    Member
    Posted 2 years ago #

    Hrm. I thought I responded to this thread. I guess not. I just wanted to say that your solution works perfectly. I disabled PDF and SWF support in Easy FancyBox and enabled iFrame, changing the link's class to class="fancybox-iframe" and it works beautifully. Thank you so very much!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic