Support » Plugin: All-In-One Security (AIOS) – Security and Firewall » Google captcha does not appear on account pages

  • Resolved Elliot

    (@mladja11)


    Hi,

    I have just figured that Google captcha is not appearing on my account pages generated using this shortcode: [woocommerce_my_account].

    Could you please take a look at this?

    Also, I am getting in the backend this message: “Your Google reCAPTCHA site key is wrong. Please fill the correct reCAPTCHA keys here to use the Google reCAPTCHA feature.”

    But this is not true. Captcha keys are correct.

    Thanks.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support hjogiupdraftplus

    (@hjogiupdraftplus)

    @mladja11

    IF I check right now with correct keys the google recaptcha with shortcode [woocommerce_my_account] works fine in my local.

    Here you mentioned that it is showing in Backend wrong key notice. It means that recaptcha site verification shows invalid key.

    Make sure you have used reCAPTCHA type:v2 Checkbox Keys. Not other type and Saved properly.

    Thread Starter Elliot

    (@mladja11)

    Hi,

    Well, yes. That is the fun part. I have checked, before I reported this. And it is V2 checkbox. I mean, obviously it is a false warning. I do not mind that…

    This is the page created with WooCommerce shortcode: https://shopnetic.de/neukunden/

    Do you see anything suspicious?

    For comparison, this is the regular login page: https://shopnetic.de/mein-konto/

    Plugin Support hjogiupdraftplus

    (@hjogiupdraftplus)

    @mladja11

    IF I check newkunden page viewsource in footer JS code is missing. It should be loaded like mein-konto page.

    var onloadCallback = function() {
     if ( jQuery('#woo_recaptcha_1').length ) {
    .........
    .........
    

    Can you please let me know which woocommerce plugin you use?
    Also I can see the WPRocket plugin seems installed, can you once deactivate it and check if it works or not and then activate again. “rocketlazyloadscript” type I can see on newkunden page not on mein-konto so asking.

    Plugin Contributor Prashant Baldha

    (@pmbaldha)

    Can you please try to test it after clearing a cache and let me know?

    Thread Starter Elliot

    (@mladja11)

    Hi,

    Sorry for being late.

    Well no. That does not help. I have disabled all actions WP Rocket may perform on that page, but that did not help. I am still not seeing capcha there.

    Plugin Contributor Prashant Baldha

    (@pmbaldha)

    @mladja11 We have contacted you on WordPress slack for the staging site credential to test. We have to need to investigate the issue deeply.

    Thread Starter Elliot

    (@mladja11)

    Hi, OK. I will respond there.

    Thanks.

    Plugin Support hjogiupdraftplus

    (@hjogiupdraftplus)

    @mladja11

    IF we check on your staging server, We found that [woocommerce_my_account] not added in post_content, you are using Oxygen editor that is why it do not consider as WooCommerce account page and not showing captcha.

    Solution : Add short code in the Post Content also as done for below page.

    https://wordpress-723838-2437034.cloudwaysapps.com/neukunden/

    Oxygen editor seems do not add content to post_content most other page builders does add to it.

    Thread Starter Elliot

    (@mladja11)

    Hi,

    Sorry for being late. It is crazy how busy we are…

    Yup. That was the solution. It works now.

    Thanks.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.