Support » Plugin: Yoast SEO » Google Cannot read my Yoast Sitemap

  • Resolved briannie

    (@briannie)


    I’m afraid the following message means nothing to me other than there is a problem.

    Fatal error: Maximum execution time of 30 seconds exceeded in /homepages/22/d659850412/htdocs/app665091123/wp-content/themes/Divi/includes/builder/main-structure-elements.php on line 3622

    Unsupported file format. Your Sitemap does not appear to be in a supported format. Please ensure it meets our Sitemap guidelines and resubmit.

    Can you assist please?

    • This topic was modified 1 year, 5 months ago by briannie.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support devnihil

    (@devnihil)

    Maximum execution time is a PHP variable that dictates how long a PHP process can run before being terminated. This setting is typically controlled by editing the values in a php.ini file such as in the following example:

    max_execution_time = 300

    If you aren’t sure how to change these settings in php.ini, we would recommend contacting your hosting provider for additional assistance.

    In regards to the ‘unsupported file format’ warning, that is likely due to the page-sitemap.xml timing out and so that Google is seeing the error that is generated, instead of the .xml file.

    I’ve had a look at php.ini file and there is no code at all similar to the line above. Can I just add that line and is the value of 300 a suitable value to resolve the problem?

    This is the present content of the php.ini file:

    safe_mode=false;
    upload_max_filesize=67108864;
    post_max_size=67108864;
    memory_limit=268435456;
    extension_dir=/usr/lib/php7.0/extensions;
    zend_extension=/usr/lib/php7.0/extensions/opcache.so;
    opcache.enable=1;
    opcache.memory_consumption=32;
    opcache.interned_strings_buffer=8;
    opcache.max_accelerated_files=3000;
    opcache.revalidate_freq=180;
    opcache.fast_shutdown=0;
    opcache.enable_cli=0;
    opcache.revalidate_path=0;
    opcache.validate_timestamps=2;
    opcache.max_file_size=0;
    opcache.file_cache=/kunden/homepages/22/d659850412/htdocs/.opcache;
    opcache.file_cache_only=1;

    Please advise what I need to do to have the Yoast XML file read by Google.

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    There should be more code in your server php.ini file. If not, we recommend you please reach out your web hosting provider and ask them to increase the maximum execution time.

    If that doesn’t resolve the issue, we recommend you please reach out the Divi theme for assistance as the error is coming from the Divi theme file wp-content/themes/Divi/includes/builder/module/settings/Migration.php.

    Thank you for getting back to me but I have now solved the problem by simply creating a Google Sitemap. Done in seconds, is dynamic and automatically submitted to Google and Bing.

    All together a much simpler solution.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Google Cannot read my Yoast Sitemap’ is closed to new replies.