Event Organiser
Google Calendar subscribe link adds calendar but without events! (3 posts)

  1. ohlauren
    Posted 2 years ago #

    Calendar: http://middletownarchery.com/calendar/
    Feed: http://middletownarchery.com/feed/eo-events/

    When I click the google link (or the webcal link, since gcal's my default handler) it asks me if I want to add this calendar - I click yes, and it shows up in the "Other Calendars" list on the side, but no events show up. Ever.

    If I click the iCal button and download the .ics file, and use "Import Calendar" to upload it, it is able to add the events successfully, so it looks like the problem is in the adding-to-google, not the feed itself, but I can't figure out what the deal is! Hulp!


  2. ohlauren
    Posted 2 years ago #

    I think I got it working, mostly. I think it's a cache thing... I must have tried adding the calendar before I put any events in it, but I found a tip for some other plugin saying to add ?nocache to the end of the url, so I deleted the calendar and tried it, and it worked.

    However, it's still not showing new events I added after that. Is that just a refresh interval thing? If so, is that interval determined by google or Event Organiser? (Judging by no events showing up between when I added it initially and figured out the ?nocache trick, if that's it, the interval must be longer than a full 24 hours, which is no good.) Is there a way to force it to update at a shorter interval? (Like, every couple minutes, for testing purposes, and then something more reasonable later.)

  3. Stephen Harris
    Plugin Author

    Posted 2 years ago #

    Google decides how frequently to refetch the feed, and while I have to admit I do not know how frequently that is, I'm certain it's much more frequent than every 24 hours. Do you have a cache plug-in installed? If you are, it may be that the plug-in is ignoring the nocache or that it is setting the headers incorrectly (e.g. telling Google there is no change, - which explains why deleting the feed and re-adding it seems to work initially).

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Event Organiser
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic