Support » Plugin: Pinpoint Booking System - #1 WordPress Booking Plugin » Google Calendar Not Syncing with Pinpoint (and pending reservation disappeared)

  • Hello,

    I tried the steps found here: https://wordpress.org/support/topic/pinpoint-booking-plugin-sync-with-google-calendar/

    Unfortunately, it seems the calendars have not synced.

    This is what I did:
    I logged into my gmail account, went into Settings, and clicked on my calendar under the “Settings for my calendars” section. I went to the “Integrate calendar” section and copied the url for “Secret address in iCal format”.

    I then logged into my website, I went to Pinpoint Booking System > Calendars > I clicked on my calendar > went to “Edit calendar settings” > scrolled all the way down to “Google Calendar Sync settings” > enabled “Enable Google Calendar Sync”, and then entered the iCal url in the “Feed URL” textbox. (I waited until all settings were saved)

    Afterwards, I booked an appointment (please see the link). The appointment showed up in the wordpress backend as “Pending” under Pinpoint’s “Reservations” page. I did this yesterday (2-22-20) in the afternoon (around 2pm or so). Today, I went to check my google calendar and did not see any appointment. I logged back into my website and under Reservations, I also did not see the Pending reservation (it just disappeared).

    I understand it takes a while sometimes for Google to sync things on their end (and you guys have no control over that), but it’s been 24 hours already and nothing synced, and my pending reservation just disappeared.

    I was wondering what I may have did wrong?

    (also, thank you so much for this awesome plugin and for all the support! I’ve used it previously and it works wonders)

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Now the “Book Now” button doesn’t even work.

    I’ve uninstalled and reinstalled the plugin, and it still does not work.

    I’ve added the availability and price for each day for the Month of March, but when I try to book something, the Book Now button does nothing.

    Any advice on how to debug this?

    Plugin Author DOTonPAPER

    (@dotonpaper)

    Hello,

    I cannot see any calendar on the page you provided. Please provide a valid link where we can see the issue.

    Thank you!

    Hello Dot,

    Sorry. I just re-installed it and it’s there now..

    I uninstalled it because I was testing out other plugins, but they weren’t very good at all haha.

    I’d like to keep using pinpoint, but for some strange reason it stopped working out of the blue. The only thing I did was I tried to sync Pinpoint’s calendar with my client’s Google calendar. I did not install any other plugins, so I know this isn’t an incompatibility issue (I installed and tested the new plugins AFTER pinpoint stopped working)

    My Calendar Settings are here:
    https://ibb.co/74D7yP2
    https://ibb.co/TqvKW37
    https://ibb.co/0YVf9XH
    https://ibb.co/7gDb1LG
    https://ibb.co/vZc1KtM
    https://ibb.co/C0ZX8hy

    I took out the google calendar sync settings Feed Url because I was debuggin the Book Now button.

    Plugin Author DOTonPAPER

    (@dotonpaper)

    Hello,

    I can see that the Book now button is properly displayed.

    Regarding Google Calendars synchronization, that reservation you made in Pinpoint didn’t disappeared but was set as “expired” in your database. It is still visible if you’ll use filter settings in Reservations.

    Indeed, when synchronizing with Google it may take a while until reservations will be synchronized.

    If you still have this problem, please send an email to support@pinpoint.world

    Thank you!

    Hi Dot,

    I can see the expired reservation now. Thank you for that.

    I saw this post: https://wordpress.org/support/topic/book-now-button-not-working/
    And your question of whether the Billing Address is enabled or not, that gave me the idea to mess around with the settings in the Payment Gateway tab.

    For ” Enable payment on arrival” and ” Enable instant approval”, both were disabled. I decided to enable “Enable payment on arrival”. The Book Now button still did not work. So, I decided to disable “Enable billing address”. So, with “Enable payment on arrival” enabled and “Enable billing address” disabled, the Book Now button worked.

    I got the friendly message that the booking was successful, and in the backend under Reservations, I saw the reservation as Pending.

    I didn’t like the fact that the “pay on arrival” radio button was there. My client doesn’t want that, so, I decided to disable that option again, and surprisingly, it worked!

    I guess moving forward, if the Book Now button mysteriously stops working, the solution is to “reset” the settings by enabling and disabling (or vice versa) settings in the payment gateway settings tab. I’ve documented this for my own personal notes. Hopefully this is helpful for others. Not an ideal solution, but it’ll do.

    I guess my last question is, why did the reservations expire so quickly? I believe that’s why it never showed up on the Google Calendar. For my other websites, the reservations do not expire like that at all. In fact, I have reservations dating back several months that are still “pending” and have not expired.

    I have 4 reservations as pending right now (all of them I created today to test the Book Now button). Now I’ll just wait to see if it syncs with my client’s Google Calendar. Before creating those reservations, I copied and pasted the “Secret address in iCal format” into the Feed URL under “Google Calendar Sync Settings” and I enabled it; I added a 300 sync time (similar to what i have for my other sites);

    • This reply was modified 2 months, 4 weeks ago by kentnerd.

    Hi Dot,

    The Pinpoint Booking calendar and the google calendar are still not auto syncing.

    Does the Post ID in the Settings have anything to do with this?
    The calendar itself has an ID of 1, but the default Post ID is 0.
    Here is an image of what I mean
    https://ibb.co/94Dxkmp

    I actually changed the default Post ID from 0 to 1.
    I hope that maybe this will fix the auto syncing issue.

    To test this, after changing the ID to 1, I booked another day on the calendar.

    If this doesn’t work, I’ll try changing the sync time back to 3600, which was default (I changed it to 300 because I thought maybe it would sync faster).

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.