Support » Plugin: Simple Calendar - Google Calendar Plugin » Google Calendar ID not working

  • In your documentation you note that the Calendar ID is an alphanumeric string found under Calendar settings-
    https://docs.simplecalendar.io/find-google-calendar-id/

    However, when I go to check my Google Calendar settings, it lists my ID as my Gmail address.

    When I enter this as the Calendar ID, I receive a GET error:

    
    Error calling GET https://www.googleapis.com/calendar/v3/calendars/chicoflax%40gmail.com/events?singleEvents=true&maxResults=2500&timeZone=UTC&timeMin=2017-12-11T00%3A00%3A00%2B00%3A00&timeMax=2019-01-09T23%3A59%3A59%2B00%3A00&key=242198729897-f0ac52h83lh3c3gokd4a56fhmfdk5m2u.apps.googleusercontent.com: (400) Bad Request

    I have verified the Google API key a number of times, so that is not the issue.

    What to do? Any assistance is most appreciated!

    • This topic was modified 10 months, 1 week ago by  homemadejam.
Viewing 7 replies - 16 through 22 (of 22 total)
  • I set up my Calendar API key at google
    I created a Google Calendar at google & shared to public (NOTE: This says “See only free/busy” in the visibility options and “See all event details” is greyed out!? this is under a custom domain gmail not @gmail.com if that matters)
    I copied my calendar ID from the Integration tab in Google Calendar Settings

    I pasted the Calendar API key into the Simple Calendar settings
    I created a Simple Calendar and gave it the Google Calendar ID.
    I verified that my Application restrictions are set to None in the Google API credentials

    I still get an empty simple calendar with none of the calendar items visible at Google Calendar displaying in my site.

    I’ve tried setting Application restrictions to None in the Google API restrictions.
    I have also tried setting it to http and setting it to my staging domain followed by “/*”.
    Have also tried it without the http:// as Jay suggests.

    The only thing that works is pasting the iframe to the Google Calendar into my page content directly, bypassing the Simple Calendar plugin.

    Still can’t get this free plugin to work.
    Thanks for any help you can provide.

    • This reply was modified 3 months, 4 weeks ago by  mweier.
    • This reply was modified 3 months, 4 weeks ago by  mweier.

    So has anyone solved this? And if not, has anyone found an alternative plugin for Google Calendars?

    I solved the problem doing this:

    • 1. You need to check if the Google Developers Console is enabled. If is not enabled please enable it.
    • 2. If your API key restrict the access try to no limit the access selecting the “none” option

    I hope this instructions help to someone.

    jkinzieh

    (@jkinzieh)

    What solved this for me was at the WordPress end of things…

    In WP
    Calendars
    Edit Calendars – Google Calendar – Calendar ID
    For this entry I took out the link and just put in the Google User/email address and the problem went away

    e.g. “googleUsersCalendar@gmail.com

    Hello I have the same issue.
    I have this Get error under the ID calendar. As for the widget, I have no calendar listed under there. Somebody care to explain exactly how you created the API credentials? instructions are outdated of course, thank you Google.
    @cdenmark you mean if I see in the APis dashboard : Activation status :Enabled?
    @jkinzieh would you care to explain what format you used?

    What I think is that they want us to pay for the addon…

    Hi @vero1238
    You need to check if your Google Developers Console is enabled

    1. Go into your domain administration @ https://admin.google.com/AdminHome
    2. Go to Apps
    3. Go to Additional Google Services
    4. Find the Google Developers Console and check if is it enabled. If isn’t you need to enabled doing click on it and then pressing the button enable.

    Additional to this you need to check if your Google Calendar is enabled. To check this you need to:

    1. Go into your domain administration @ https://admin.google.com/AdminHome
    2. Go to Apps
    3. Go to G Suite
    4. Find the Google Calendar service and check if is it enabled. If isn’t you need to enabled doing click on it and then pressing the button enable.

    For your API Key:
    1. Log in to your Google Cloud Platform API & Services
    2. Click on your API Key
    3. In Restrictions Area put your website like this yourname.com/* or put the restriction to none.

    That’s how I solved the problem and you don’t need to buy the addon, for me this free plugin is working pretty well 😉

    OK thank you for the detailed explanation.
    I don’t have a G Suite account. So the plugin can’t work without?

Viewing 7 replies - 16 through 22 (of 22 total)
  • You must be logged in to reply to this topic.