Support » Plugin: Simple Calendar - Google Calendar Plugin » Google Calendar ID not working

  • In your documentation you note that the Calendar ID is an alphanumeric string found under Calendar settings-
    https://docs.simplecalendar.io/find-google-calendar-id/

    However, when I go to check my Google Calendar settings, it lists my ID as my Gmail address.

    When I enter this as the Calendar ID, I receive a GET error:

    
    Error calling GET https://www.googleapis.com/calendar/v3/calendars/chicoflax%40gmail.com/events?singleEvents=true&maxResults=2500&timeZone=UTC&timeMin=2017-12-11T00%3A00%3A00%2B00%3A00&timeMax=2019-01-09T23%3A59%3A59%2B00%3A00&key=242198729897-f0ac52h83lh3c3gokd4a56fhmfdk5m2u.apps.googleusercontent.com: (400) Bad Request

    I have verified the Google API key a number of times, so that is not the issue.

    What to do? Any assistance is most appreciated!

    • This topic was modified 1 year, 9 months ago by  homemadejam.
Viewing 15 replies - 1 through 15 (of 23 total)
  • simplecalendarsupport

    (@simplecalendarsupport)

    Hi,

    Thanks for reaching out! We’re sorry you are facing this issue. Please open a support ticket at https://simplecalendar.io/contact/

    Take care.

    Hello SimpleCalendarSupport,

    I went and tried to repost this support request at the URL you supplied but the form there requires that I enter “any of your Simple Calendar premium add-on license keys”.

    I do not have any premium add-on license keys. I just have the free version of this plugin without any add-ons, premium or otherwise.

    Is support only available for premium customers?

    Similar problem.

    Running php 7.0 (single php.ini) on shared hosting at Bluehost.

    Have double checked and have correct calendar ID. Also entered API key from google dev site for calendar. Have also checked to ensure curl, iconv, json, and mbstring are active on server.

    Have also disabled iThemes Security and several other plugins for potential conflict but problem persists.

    While trying to retrieve events, Google returned an error:
    
    Error calling GET https://www.googleapis.com/calendar/v3/calendars/gd3q3p2vq877i1oninq5crk84o%40group.calendar.google.com/events?singleEvents=true&maxResults=2500&timeMin=2017-12-12T00%3A00%3A00%1B00%3A00&timeMax=2020-01-10T23%3A59%3A59%1B00%3A00&key=AIzaSyDImveOI9k8Iv-jzbdKFg7lmUg3g2O4yh4: (403) The request did not specify any referer. Please ensure that the client is sending referer or use the API Console to remove the referer restrictions.

    Any updates on resolving. 🙂

    • This reply was modified 1 year, 9 months ago by  waterworks2.
    • This reply was modified 1 year, 9 months ago by  waterworks2.

    I am getting this error as well, until I change the setting under
    Edit Calendar
    Calendar Settings – right at the top
    I change it from Google Calendar to Grouped Calendar since this calendar is one of many under the user profile (and if you notice your error also refers to “group.calendar.google.com”)

    However, thenthe first error disappears but another error appears that I do not know how to solve:
    Warning: uasort() expects parameter 1 to be array, boolean given in /home/content/83/7881983/html/wp-content/plugins/google-calendar-events/includes/feeds/grouped-calendars.php on line 164

    And when the calendar appears there is no arrow to navigate to future months.

    Same issues here and the above doesn’t apply to me – I have only one calendar under one user profile.

    Same problem here… Seem to be solved disabling the restrictions on the api key. But You are without restrictions. The error message seems to say that the site is not identifying itself, so it is out of the allowed ones.

    Add me to the list of people with this problem.

    I thought I was having trouble because the instructions are out of date. I had figured out what to do, but the plugin is broken the same way everyone else describes here.

    I’m also getting this error when I’m making restrictions in my calendar. The documentation is out of date anyway because Google is changing their UI every day it seems. A solution is most welcome.

    • This reply was modified 1 year, 6 months ago by  Cicero83.

    include me in this “Error calling GET” issue.

    Jacob

    (@jake33)

    WCBRS 2019 Contributor

    Same issues here.

    Out of date instructions and lack of support to a common question makes this very frustrating. Going to try another solution..

    Me too, double checked all values… seems like the plugin does not work.

    Ditto.

    Oddly enough, my short code displays a calendar when only the Calendar ID is entered, but it is blank and will only navigate backward. Once I add the API key, then I get the “Error calling GET” issue.

    FYI: The screenshots in the documentation are outdated version of Google Cal. And the only Calendar ID lists my email address.

    More than 5 months since the first post and nothing?
    Google changed some settings and instructions are outdated.

    Same problem here…

    I am seeing this as well

    To fix the restriction error

    Log in to your Google Cloud Platform API & Services and for the key, edit it and remove the http from the url or just remove the restrictions all together.

    So instead of http://yourwebsite.com/*
    yourwebsite.com/*

    You may still see the error message in the admin, but the calendar will display.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Google Calendar ID not working’ is closed to new replies.