WordPress.org

Forums

Google basemap doesn't appear when using Javascript to combine Fusion Tables (2 posts)

  1. kategolden
    Member
    Posted 3 years ago #

    I'm a non-coder stumbling around in javascript — so this may be a very easy answer.

    I'm drawing up a Google map that includes data from two Fusion Tables as layers. Unfortunately I can't post the example, as it's unpublished professional work, but I did put the code in a pastebin: http://pastebin.com/YgAg84Re

    I essentially copied the code from a tutorial on doing just this sort of thing.
    http://michelleminkoff.com/2011/08/21/how-to-combine-multiple-fusion-tables-into-one-map/

    Then I simply copied the code into the HTML editor of WP.

    The layers draw up beautifully, but the basemap, the gmap, doesn't appear. Or rather it does flash in there for an instant and then disappears or is covered up.

    WP does not appear to have stripped the code out (I never use Visual mode). I did find the Codex guide to using Javascript, which suggests that copying Javascript straight into a post is usually inadvisable. But I can't quite make sense of it, lacking a basic understanding of how these things all work together.

    I'd be grateful if anyone could point me to possible solutions.

    Thanks!

    Kate

    (Incidentally, i've filed this under WP-Advanced, but not sure that is the most appropriate category.)

  2. kategolden
    Member
    Posted 3 years ago #

    I've also tried using the Code Embed plugin. Same result. Anyone?

Topic Closed

This topic has been closed to new replies.

About this Topic