WordPress.org

Support

Support » Themes and Templates » [Resolved] Google API Fonts broken

[Resolved] Google API Fonts broken

  • Hi there,

    I was using Oxygen for quite some time without issue and recently when the brute force attacks began happening on WordPress sites my Oxygen theme started acting funny.

    If you browse to http://www.onthewaytosomewhere.com you will see that the title, top menu and a few other areas display Times New Roman instead of Abel (and other fonts).

    If I simply login to my dashboard (wp-admin), it fixes the problem. The fonts will display for maybe 2-3 days and then revert back to Times New Roman.

    I know when the attacks began some time ago, my host did change their server configurations and I did install Better WP Security. I have not changed anything from the standard configuration of this theme.

    If anyone has any thoughts or suggestions to try I would really appreciate it!

Viewing 4 replies - 1 through 4 (of 4 total)
  • It’s Better WP Security. It’s stripping query parameters off scripts and stylesheets in a misguided attempt to “harden” your site by hiding version numbers. It’s a bad idea, as you’ve discovered.

    See this related support answer, and change your setting for “Display random version number to all non-administrative users” which is apparently the culprit.

    Or dump that plugin and find out how to harden your site without magical security plugins that break things 🙂

    cheers,
    Ross

    Thanks Ross, I have disabled it and will see how it goes.

    Really appreciate the quick reply!

    Yup, that fixed it. (you can test by logging out of your wp-admin and viewing the homepage)

    cheers,
    Ross

    Thanks again Ross.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Google API Fonts broken’ is closed to new replies.