Support » Plugin: WP eCommerce » Google Analytics not working

  • Resolved Bloke


    I set up ecommerce on my Google Analytics account. In WPEC I have my tracking ID entered. Checked enable Google analytics, checked tracking code present and advanced mode. But its not tracking the transactions. Just the ecommerce goals I set up. Is there anything that I can do to fix this? I tried removing the tacking code and just selecting the box to enable and I looked at the source code and don’t see it being added either.

Viewing 4 replies - 1 through 4 (of 4 total)
  • I tried this approach described here and it doesn’t work. Has anyone got it working? In WPEC there are settings so this should work without manually adding all this code.

    Plugin Author Justin Sainton


    Hi Bloke!

    Would you be able to do a couple things to help us debug? The first would be to run a transaction on the site, then, on the Transaction Results page, “right-click” on the page, click View Source. If you can copy and paste the source code from that page into a gist, that will actually be super helpful.

    Lastly, if you can take a screenshot of your settings on the Google Analytics area for WP eCommerce, that would be helpful as well. With those two bits of info, we should be able to help you get to the bottom of this.

    Since my last post it did record the transaction with the code above. On my settings I have enable Google Analytics checked. I have tracking code present unchecked and advanced mode unchecked. Also have my Google ID in the box. I hope to have another transaction soon so that I know its working. How should I have it set up instead of adding this custom code? Also it recorded the transaction amounts double. I read that this happens sometimes if someone bookmarks the checkout page?

    I was able to work it out. WPEC was adding GA code and also had my custom code on the page. Was able to text it locally. Still can’t figure why Google will record most transactions correctly and sometimes the transaction amount is wrong. But that is another issue. I know its getting sent correctly. A transaction for $6,123.99 for example recording as $6.00. There isn’t a product for $6.00 and its not rounding it. This only has happened for 2 large transactions.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Google Analytics not working’ is closed to new replies.