WordPress.org

Support

Support » Plugins and Hacks » "Google Analytics for WordPress" re-authenticate

"Google Analytics for WordPress" re-authenticate

  • Miltiadis

    @miltiadis

    Guys i have problem as i plugin google analytics….it says:
    “Google Analytics is not active. You must select which Analytics Profile to track before it can work.”
    Is there any solution?!

Viewing 15 replies - 1 through 15 (of 25 total)
  • Dan Bissonnet

    @asinglehumanbeing

    The plugin needs the UA tracking ID from Google so it can generate the appropriate code for your site.

    Just go to Settings->Google Analytics in the admin menu. Click ‘Click here to authenticate with Google’ and follow the instructions. Then you can choose which analytics profile you want to use.

    Miltiadis

    @miltiadis

    sorry i didnt brief you further and thanks for response. I did that and i get this:

    “Unfortunately, an error occurred while connecting to Google, please try again:Re-authenticate with Google”

    i use firefox (also i have google account for mails)…i dont know if that information change anything(?) or if i must to do anything else to get the authentication..

    Dan Bissonnet

    @asinglehumanbeing

    Google needs to be able to communicate with your site in order to authenticate properly – your server configuration may be preventing it.

    If it fails, then it’s probably easier to just choose ‘Manually enter UA code’ type the UA code from your Analytics account instead.

    Miltiadis

    @miltiadis

    It works!! thank you asinglehumanbeing:)

    Dan Bissonnet

    @asinglehumanbeing

    No problem – glad you got it working.

    I’m getting the same “Not active” message, I have chosen a profile, entered my UA code manually and each time it just takes me back to the wp-admin login screen then back to the same “not active” message. I have un-installed/deleted the folder/re-installed but it’s always the same. Always asks me for login details twice as well. Everything was working fine up until 23 August when I think I upgraded – is this the problem? Should I downgrade back to 3.0?

    Joost de Valk

    @joostdevalk

    Rigaud: no, you just need to follow asinglehumanbeing’s awesome instructions above. Either click authenticate, and if that doesn’t work, enter the UA code manually.

    Joost de Valk

    @joostdevalk

    asinglehumanbeing: thanks for taking the time to answer these questions, I really appreciate it 🙂

    Dan Bissonnet

    @asinglehumanbeing

    No problem Joost. Thanks for making a great plugin!

    Sorry for the delay the update has only just hit my inbox. Have tried everything listed above more times than I care to remember. It all used to work fine, then I upgraded wordpress now nothing on the blog registers at all.

    I click on this link

    “Google Analytics is not active. You must select which Analytics Profile to track before it can work.”

    It takes me to a page which looks like a HTML site map, underneath is this

    “Google Analytics for WordPress Configuration”

    I’ve only got 1 account, I select that, it auto enters my details in the profile box which correct UA code, I press “Update Google Analytics Settings”

    It takes me back to the wp-admin login page, I enter my details, it refreshes that page, I enter my details again and it takes me back to the WP dashboard and we start all over again.

    Same thing happens if I enter my UA manually.

    Some times it takes me to Google analytics page asking to allow or deny access, I click allow, it takes me back to the HTML site map with nothing entered in the settings and I start all over again.

    Sorry for the long post and I don’t want to waste your time but it’s driving me insane.

    Has nobody else had this problem? I had a problem with another plugin when I upgraded to WP 3.0.1 – WPtouch – which renders the site for iPhone but I just un-intalled/re-installed and it worked fine. I’ve tried this with the google analytics plugin but I just end up at the same place.

    Dan Bissonnet

    @asinglehumanbeing

    @rigaud: If its logging you out when you update the settings, that sounds like a more complex issue.

    Have you tried disabling all other plugins first? It could be a conflict with something else that’s been updated.

    asinglehumanbeing thanks for the advice – tried it but no difference – looks like I’ll have to find another way of tracking the blog. Bit of a shame, it’s worked for 18 months no problem.

    I had a similar problem of being repeatedly unable to authenticate with Google. In my Google account, I added my domain to the “websites authorized to access your account.” It still didn’t work, nor did any other Google Analytics plugins, which indicated I was missing something obvious here.
    As a first-time user of Google Analytics, I did not realize that I had to create an account at Google Analytics. Once I did that, listed my domain there, got my UA code, and manually entered it in Google Analytics for WordPress, I was good to go. Note that when you’re in Google Analytics, you don’t need to copy and paste the code it gives you into the head of your webpage (your wordpress header.php), because the plugin does that for you.
    If you’re having trouble authenticating, maybe some of you are having this same problem. Sometimes the simplest things are the ones you can’t find any support for, because everyone thinks you already know them (try searching online for a recipe for making simple oatmeal if you forgot the water/oats ratio).

    jeffreyhmartin – tried all that, I’ve had google analytics running on the site for about 2 years and up until 23 August the plugin has worked fine. I updated to wp 3.0.1 and my php on the server to v5 at about the same time so something has gone amiss somewhere. I’ve installed another plugin to see how that goes, it’s seems to be fine so far, has let me install and edit options so will have to wait a couple of days to see results. Thanks for your help and time though.

    I’m just adding in my two cents here, like jeffreyhmartin, I thought the plug-in was a stand alone and didn’t realize (or see any instruction anywhere) that I needed to register separately with Google for their analytics service. Once I did I had to manually copy the UA code over. After I did that, I thought the plug-in would activate Google Analytics within my WP dashboard. I didn’t realize I needed to go over to Google to see the information.

    This is completely basic, but would be very helpful for other newbies like me if this was stated clearly in the plug-in download FAQ information.

    Best, Wendy

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘"Google Analytics for WordPress" re-authenticate’ is closed to new replies.