WordPress.org

Forums

Google Analytics Broken in WP 2.6? (5 posts)

  1. rushnp774
    Member
    Posted 6 years ago #

    I've installed Google Analytics on my sites with ease before, and inserted the code correctly (before the </body> tag in footer.php) and Google says it's receiving data. But it's not.

    A WordPress stats program I have shows visitors and even tracked some of the incoming keywords they used to find me.

    Anyone else having this problem? What should I do?

    Kyle

  2. phanvincicode
    Member
    Posted 6 years ago #

    I ran into the same problem. Not being a PHP developer is making my life much difficult. According to the documentation - the following line has to be added before </body>

    <?php wp_footer(); ?>

    Till now I did not see any stats. So anyone facing the same problem? Or is it better to go to the previous version?

  3. Chris_K
    Member
    Posted 6 years ago #

    @rushnp774 - My Google Analytics works just fine with 2.6 blogs. I really don't think GA cares what version of WP you're running -- as long as you've added the code to the current theme.

    Did you make sure that your upgrade didn't undo any manual theme edits you might have done to get GA code in your theme?

    Or are you running some sort of plugin that handles Google Analytics?

    @phanvincicode - so... you added that line to your theme's footer.php right? You don't need to be a coder to edit files :-)

    You must be using some sort of plugin though. Google Analytics, by itself, sure doesn't need that.

  4. rushnp774
    Member
    Posted 6 years ago #

    For some reason, it just took a few days after Google Analytics said the tracking code was working until it started collecting data. It appears to be working fine now. Odd...

  5. infozoft
    Member
    Posted 6 years ago #

    This happened to me too. After some days it was alright.

Topic Closed

This topic has been closed to new replies.

About this Topic