Support » Plugin: AMP for WP - Accelerated Mobile Pages » Google Analytics

  • There are placement for Tag Manager ID and Analytic ID. Am I correct but it’s a either / or and do not need both since GTM has the Analytics ID built in?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Either with GTM or regular GA I’m not seeing any analytics being recorded.

    With the google tag assist chrome extension I’m getting the following error.

    HTTP response code indicates tag failed to fire: Status 403

    This is the code placed at the footer of the page.

    <amp-analytics id=”amp-gtm-googleanalytics” type data-credentials=”include” config=”https://www.googletagmanager.com/amp.json?id=GTM-1234&gtm.url=SOURCE_URL”><script type=”application/json”>{“vars”:{“account”:”UA-696123123-3″},”triggers”:{“trackPageview”:{“on”:”visible”,”request”:”pageview”}}}</script></amp-analytics>

    I change some of the GTM / UA numbers with 123123 to hide my actual ID but something is failing here.

    Suggestions?

    Plugin Author Ahmed Kaludi

    (@ahmedkaludi)

    Hey @mrzimmy

    That’s really strange. Let me properly check this over the weekend.

    I have also made a trackable ticket about this: https://github.com/ahmedkaludi/accelerated-mobile-pages/issues/700

    Regards,
    Ahmed

    @ahmedkaludi

    There has been no movement on this or follow up. This analytic issue is pretty major. Can I get an update please?

    • This reply was modified 3 months, 1 week ago by mrzimmy.
    Plugin Contributor ampforwp

    (@ampforwp)

    Hey @mrzimmy

    We are already communicating with you over email. Could you please check our recent mail?

    Hi @ampforwp

    I have emailed / replied and communication back has been slow to little about status updates or trouble shooting the analytic bug. I finally see a little movement on the Git post. I have been looking at other clients that use GA and none that I can see are recording any GA stats. I’m not sure if they are aware but it’s a pretty big bug if you can’t record and show the value of the AMP pages.

    Thanks.

    Hello @mrzimmy

    Really sorry for the late reply, I have personally visited the URL’s you have provided on the GitHub issues page here

    The issue was because if misleading UI in the Section, Please enter the second parameter i.e. Type as googleanalytics in AMP analytics section

    that will fix the Issue since on the page source that was missing parameter

    Regards
    Khaled

    • This reply was modified 2 months, 3 weeks ago by Khaled.
Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.