Support » Plugin: Facebook Instant Articles & Google AMP Pages by PageFrog » GOOGLE AMP HTML Does Not Work: Wheel Keeps spinning

Viewing 15 replies - 1 through 15 (of 15 total)
  • Note: trying to turn on amp for all posts and pages. 30 posts and 4 pages. I have Version 1.0.7.

    I’ve got the same thing happening where the wheel just keeps spinning for over 2 hours now.

    Same issue as well

    Same here

    good thing is that all my errors are dropping each day with the AMP indexing links going up so it’s working!

    Plugin Author pagefrog

    (@pagefrog)

    Hi pxforti, gooma2, nbostic, and Dobbelsoft,

    Thanks for the feedback, would love to help get this fixed but I’m having some trouble replicating the issue. Which version of wordpress are you on? If you know your version of msql that might also be helpful. Are you able to open the debugging console and see if there are ajax network requests being sent? What are the parameters being sent and what are they returning?

    Thanks so much for your help debugging this, it’s currently #1 PageFrog most-wanted bug 🙂

    look better before updating plugins on ssl/non ssl connector, now i get validation had errors:
    invalid value ‘//fonts.googleapis.com
    ‘amp-analytics extension, .js script’ tag is missing or incorrect,
    tx.error @ validator.js
    (anonymous function) @ validator.js
    f.ca @ validator.js
    Mw @ validator.js
    Hw @ validator.js
    Aw.vb @ validator.js
    xw @ validator.js

    i use wp 4.4.2, php 5.6

    i hope the plugins can be fixed again.

    Plugin Author pagefrog

    (@pagefrog)

    Hi kutuliskan,

    Those errors sound more like AMP validation errors. AMP requires that fonts and scripts are loaded over https (they cannot be protocol independent). You probably have a plugin or function that removes http or https from your scripts, fonts and css. You’ll have to turn off that functionality wherever it is being done.

    In version 1.0.7.2 (will be posted shortly) we’ve included a feature that attempts to do this automatically. In your admin, just go to Mobile Formats -> Settings and check the box that says “Force AMP compliance by removing other plugins/functions from AMP pages”. Then click Save all Settings and check your page again (make sure the page isn’t cached or anything). The errors should be removed.

    Just figured out the problem: Safari / Mac. I tried it in chrome and it works.

    Note: I disabled the one safari plugin installed but it still doesn’t work on safari

    Thanks for the tip, pxforti. That ended up being exactly my issue as well. Doesn’t work in Safari for me, but Chrome works.

    Works fine in Chrome (not with Safari)

    Hi Pagefrog, i was investigating for script errors, i do nothing because i make amp for custom themes, i have problem with integrate amp plugins to my custom theme … thanks you

    Plugin Author pagefrog

    (@pagefrog)

    Hi pxforti, cdgeog, and Dobbelsoft,

    Mike here from PageFrog—happy to hear that you guys got it working on Chrome! Also thank you so much for helping me spot this issue with Safari. Admittedly I do most of my testing on Chrome so I haven’t been giving Safari the love it deserves.

    I’ll include a Safari fix in the next update of the plugin!

    Also, kutuliskan, could you give me a bit more details on the problems you’ve been encountering with your custom theme?

    Just ran into this one myself. Here’s the specific jQuery error in Safari:

    Screen Shot

    Plugin Author pagefrog

    (@pagefrog)

    Hi Nick Ciske,

    We just released an update that fixes the issue in your screenshot there! Please update PageFrog and try again 🙂

    Also everyone,

    The update we just released fixes all known issues around the Enable AMP button, so all the above issues should now be resolved!

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.