Support » Plugin: Better Click To Tweet » Google AMP

  • Resolved zendokan

    (@zendokan)


    Please advise when the plugin is compliant with Google AMP. The current version is injecting third party scrips which are not allowed by Google AMP. Cheers!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Ben Meredith

    (@benmeredithgmailcom)

    Do you have more specifics about this? Without going to check and confirm, I’m pretty sure all the scripts added here are added by the plugin itself, not a third party. They are all loaded from your site.

    I’m not super-familiar with AMP but would love to have as many users as possible if my plugin. So if you can give me specific scripts that are causing problems I’m happy to take a look.

    I passed your question to my developer. He can give the specifics. Please hold on.

    Plugin Author Ben Meredith

    (@benmeredithgmailcom)

    Sounds great! Let me know!

    Hi, There are pure amp sites (1), there are customized WordPress amp sites (2) and there are plugin amp sites (3) with the /amp extensions, like ampforwp. This is why my developer doubts if it is possible to support amp with just one BCTT plugin.
    The key thing is: Third-party scripts means other than Google AMP scripts. Also called custom javascripts. We need to embed the styles into the <head> and there should be only one <style> tag. We think this is the hardest thing to achieve. Cheers!

    • This reply was modified 7 months, 1 week ago by  zendokan.
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Google AMP’ is closed to new replies.