Support » Plugin: Quantcast Choice » Google Adsense Problems and Notice

  • Hi, we are writting because Google Adsense sended a notice about TFC 2.0:

    – Error: 2.1a
    – Description: Tag or SDK isn’t receiving a TC string due to CMP status being stub, loading, or error.
    – Suggested action to take: Ask your CMP to make sure that their APIs are properly implemented based on the IAB TCF tech spec.

    Please, could you help to solve this problem after implementing TFC 2.0 from Quantcast?

    Thanks in advance!

Viewing 15 replies - 1 through 15 (of 196 total)
  • Plugin Author Ryan


    Hi @ibiza69, thank you for reporting this issue, we are looking into it now.

    Thread Starter ibiza69


    @rbaronqc thank you!

    Thread Starter ibiza69


    Please @rbaronqc, share update with us when you resolve the issue, so we can check if things are solved at Google Adsense 🙂 Thank you!

    Same issue here on 5 different websites and 2 different Quantcast accounts.
    Google Chrome console reports this error:

    Failed to load resource: the server responded with a status of 403 ()

    Access to denied
    You are not authorized to see this page
    HTTP ERROR 403

    Thank you for your help

    Plugin Author Ryan


    @here Actively working with the product engineering team to solve this issue. I will update the ticket here once I have any new information.

    Plugin Author Ryan


    @sanmag can you see if you are still getting a 403 error found for the resource url you listed above? I was able to view/access that resource. Are you still seeing the issue mentioned above? Also, do you know if you are using Global scope for your CMP settings?
    “Global Scope and Out of Band Vendors Are Not Allowed Google policies require that publishers use either (a) service-specific scope or (b) group-specific scope. Google does not support Global scope or Out-of-band.”

    Sorry, I’m still getting the same error. I have checked my settings and I have enabled purposes 1, 3 and 4.
    Is there anything else I can try?
    Thank you

    Hi, Am writing about a similar issue because Google Adsense sent a notice about TFC 2.0 to me as well.

    please help me fix it. @rbaronqc

    Thank you

    Hi, same problem on my websites.

    Any update on this problem @rbaronqc ?


    Plugin Author Ryan


    @here still working with the Choice product engineering team to solve this issue.

    I don’t think it is a problem with the WordPress plugin only. I think it’s a problem on the Quancast Choice side.

    I’m seeing this kind of Adsense errors in other websites not made with WordPress (e.g: a Drupal site with Quancast Choice installed).

    Plugin Author Ryan


    @goddamnnoise could you go into your account and click to edit your website. In the general settings you can choose which version of the CMP you would like to use, it defaults to the latest version (v9), can you switch it to v8 and see if you are seeing the same errors on your end?

    • This reply was modified 2 years, 7 months ago by Ryan.

    @rbaronqc Kindly notified us once it’s fixed so we can check from Adsense. Thanks alot

    I can’t see 403 errors. I can only see the errors reported by Google Adsense. Sorry, I can’t change the Quancast Choice configuration.

    The errors reported by Google Adsense are: 1.1 and 2.1a

    The explanation of this kind of errors is here:

    I hope it helps.

    • This reply was modified 2 years, 7 months ago by Goddamn Noise.
    Plugin Author Ryan


    @here We appreciate everyones patience as we continue to investigate the reported issues, and we will update the support channel here with any progress.

    Today is the first day that Google is listening and using to TCF v2 signals, we trying to determine what is expected behavior based on configuration vs issues that need to be resolved.

    There are certain configuration options that could cause Google to not work. For anyone seeing issues related to Google can you please check the article here: which addresses Google consent requirements.

    For instance:

    • <div>Active Fingerprinting is Not Allowed</div>
      <div>Google will not work with vendors who register for Special Feature 2 and have an opt-in for it. Special Feature 2 refers to actively scanning device characteristics for identification.</div>
    • So if you have the “Special Feature 2 refers to actively scanning device characteristics for identification.” feature enabled, in the CMP it does not comply with Google’s privacy requirements.

      We added some additional Google consent options to the CMP that you can read about here:

Viewing 15 replies - 1 through 15 (of 196 total)
  • The topic ‘Google Adsense Problems and Notice’ is closed to new replies.