Support » Plugin: Mailchimp for WooCommerce » good plugin but problems at the moment!

  • i love the plugin but at the moment i have problems with it:

    Mailchimp says: API Request Error – 503 :: on 1474 in /data/web/xxxxx/html/apps/wordpress-36133/wp-content/plugins/mc-woocommerce-2.1.11/includes/api/class-mailchimp-api.php

    i already tested if my ip is blocked but everything seems fine
    i see that multiple other users have that issue. please fix 🙂
    thank you!

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author ryanhungate

    (@ryanhungate)

    Hey @richardhofer83 – This sounds as if you’re on a machine that has either 1 of 2 scenarios. Let’s see if we can come up with a quick solution first.

    1. You are on a shared hosting plan and the IP address that you’re using is being used by multiple domains. This can cause Mailchimp Akamai blocking for a number of reasons. We suggest getting a dedicated IP address for your site.

    2. Your website is already using a dedicated IP address, but you’re still on a machine that is making use of number 1 above, and PHP is using that IP address ( the first entry on the machine ). Again, can be blocked for a number of reasons.

    If you are using a dedicated IP address – there is a solution. We allow overrides to the outbound CURL IP ADDRESS as of version 2.1.13 which allows you to specify an IP address to use for communications with Mailchimp. All you have to do is add a config definition of MAILCHIMP_USE_OUTBOUND_IP in your wp-config.php file.

    Usage would be as follows: define('MAILCHIMP_USE_OUTBOUND_IP', 'your.ip.here');.

    Let’s give this a try first and see if your problems go away 🙂

    thank you for your reply!

    i spoke with my provider, i have indeed a shared IP with other sites. at the moment its not possible to have a dedicated IP.

    my providers is migrating my page to antother server with a another IP adresse and i will check tomorrow if it works now.

    i get back to you when i know more!

    hi @ryanhungate,
    i got a new IP adresse now but it is still shared…

    here are the results of the SSH command:

    *   Trying 92.123.24.189...
    * TCP_NODELAY set
    * Connected to us12.api.mailchimp.com (92.123.24.189) port 443 (#0)
    * ALPN, offering h2
    * ALPN, offering http/1.1
    * Cipher selection: ALL:!EXPORT:!EXPORT40:!EXPORT56:!aNULL:!LOW:!RC4:@STRENGTH
    * successfully set certificate verify locations:
    *   CAfile: /etc/ssl/certs/ca-certificates.crt
      CApath: /etc/ssl/certs
    * TLSv1.2 (OUT), TLS header, Certificate Status (22):
    * TLSv1.2 (OUT), TLS handshake, Client hello (1):
    * TLSv1.2 (IN), TLS handshake, Server hello (2):
    * TLSv1.2 (IN), TLS handshake, Certificate (11):
    * TLSv1.2 (IN), TLS handshake, Server key exchange (12):
    * TLSv1.2 (IN), TLS handshake, Server finished (14):
    * TLSv1.2 (OUT), TLS handshake, Client key exchange (16):
    * TLSv1.2 (OUT), TLS change cipher, Client hello (1):
    * TLSv1.2 (OUT), TLS handshake, Finished (20):
    * TLSv1.2 (IN), TLS change cipher, Client hello (1):
    * TLSv1.2 (IN), TLS handshake, Finished (20):
    * SSL connection using TLSv1.2 / xxxx-xxxx-xxxx-xxx-xxxx
    * ALPN, server accepted to use h2
    * Server certificate:
    *  subject: C=US; ST=Georgia; L=Atlanta; O=The Rocket Science Group, LLC; OU=IT; CN=*.api.mailchimp.com
    *  start date: Apr  9 00:00:00 2018 GMT
    *  expire date: Jul  9 12:00:00 2019 GMT
    *  subjectAltName: host "us12.api.mailchimp.com" matched cert's "*.api.mailchimp.com"
    *  issuer: C=US; O=DigiCert Inc; OU=www.digicert.com; CN=GeoTrust RSA CA 2018
    *  SSL certificate verify ok.
    * Using HTTP2, server supports multi-use
    * Connection state changed (HTTP/2 confirmed)
    * Copying HTTP/2 data in stream buffer to connection buffer after upgrade: len=0
    * Using Stream ID: 1 (easy handle 0x559e26ee8d60)
    GET /3.0/?apikey=xxxxxxx HTTP/1.1
    Host: us12.api.mailchimp.com
    User-Agent: curl/7.52.1
    Accept: */*
    
    * Connection state changed (MAX_CONCURRENT_STREAMS updated)!
    < HTTP/2 200
    < server: openresty
    < content-type: application/json; charset=utf-8
    < content-length: 3817
    < vary: Accept-Encoding
    < x-request-id: xxxxxxxxxxxxxxxxx
    < link: <https://us12.api.mailchimp.com/schema/3.0/Root.json>; rel="describedBy"
    < date: Tue, 26 Feb 2019 08:51:46 GMT
    <
    
    Plugin Author ryanhungate

    (@ryanhungate)

    @richardhofer83 thanks for getting back to us on this issue.

    I do understand that your host moved you to a new IP, but is it still a shared IP, or did you purchase a dedicated one?

    If you’re still experiencing issues with being blacklisted by Akamai getting a 500+ error coming from Mailchimp – you’ll just need to consider moving to another web host that would allow you to use your own IP address. It is a possibility that the new IP they have given you will work – but it’s recommended to use your own dedicated IP.

    If you did end up getting the dedicated IP, you’ll just simply need to use that configuration for the plugin we suggested above of:

    define('MAILCHIMP_USE_OUTBOUND_IP', 'your.ip.here');

    Let us know if we can be of any other help of course.

    i think thats not going to play, i wont get a dedicated IP. i think to expensive.
    its funny because it all worked until couple weeks ago. maybe it was a new update from wordpress / theme / ?? that caused that problem

    or did mailchimp decide to change their policy?

    i just hope that in one of the next updates it will work again as before…

    Plugin Author ryanhungate

    (@ryanhungate)

    @richardhofer83 ok – it’s not mandatory that you get a dedicated IP – but we’re trying to solve the issue of connectivity – and if you’re getting a 503 error from Akamai – that really does mean something is wrong that needs addressing at the server level.

    Have you already changed your IP address in the configuration options which were mentioned above as a solution? There is a possibility that your machine still has multiple IP addresses – and we just need to make sure that the CURL requests are using YOUR IP that is associated with your actual domain itself. This is what that configuration is for.

    Please let us know if you’ve done that already – it would impact our next response.

    ok i try that and get back to you!

    i did that, now it says:

    CURL error :: bind failed with errno 99: Cannot assign requested address

    Mailchimp says: API Request Error – 500 :: CURL error :: bind failed with errno 99: Cannot assign requested address on 1520 in /data/web/xxx/html/apps/wordpress-36133/wp-content/plugins/mailchimp-for-woocommerce/includes/api/class-mailchimp-api.php

    Plugin Author ryanhungate

    (@ryanhungate)

    @richardhofer83 just to be clear on this question – you didn’t use your personal IP address did you? You actually used the IP address of your A record from your DNS server which is assigned to your actual domain itself?

    the IP i used is assigned to the webserver my site is on. my domain “uses” this IP via A-record
    but its still not a dedicated IP, i share this IP with other sites on the same server.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘good plugin but problems at the moment!’ is closed to new replies.