Support » Plugin: AMP » Good but check your website thoroughly

  • traceyweb

    (@artisanweb)


    At first I was very impressed with the plugin and how it speeded up the website in Google’s page speed test. However, when I checked the home page the thumbnails for recent posts weren’t displaying. After some checking I found I needed a different Elementor widget (part of the pro version which luckily I had paid for) and then it worked. Later in the day I was doing something on the website and noticed a form on a landing page wasn’t displaying. I then checked a few other landing pages and the signup forms weren’t displaying. These were added using embed code (not javascript) from the mailing provider. In the end I had to disable the plugin as I just didn’t have time to research and figure out how to fix it. Perhaps it can be fixed but my advice is definitely to check your website to make sure everything works as it should.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support James Osborne

    (@jamesosborne)

    Hi @artisanweb,

    Thanks for your review and sorry to hear you’re not fully satisfied with the plugin, we take all these reviews on board. While I didn’t see a support topic open from which we can assist you are correct that it’s always important to check the AMP version of your site before implementing. While features of Elementor are not fully AMP compatible there are workarounds or alternatives in many cases.

    We’ve also made great effort to keep users informed of possible incompatibles, by adding an FAQs page which includes an Elementor reference, a setup Wizard and additional documentation & videos.

    If you’d like to share your site URL and are willing to give AMP another try I’d also be happy to check the embed code you’re using?

    Plugin Author Weston Ruter

    (@westonruter)

    Thank you for the honest review. You’re right that checking the site thoroughly is important and we’re not emphasizing that enough at the moment. I’ve filed an issue to implement that: https://github.com/ampproject/amp-wp/issues/6071

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this review.