Support » Plugin: Blog2Social: Social Media Auto Post & Scheduler » Good and yet problematic

  • joshualee55

    (@joshualee55)


    I like this product because of the UI and set up.
    But my biggest disappointment is with the connection to server.

    It either caused google to prompt me for security breach, asking me to change password or the plugin took such a long time to load that it timed out, even though i have increased all the parameters.

    this does not happen to me but to all my clients that i have installed this.
    We have to use this with our finger crossed as sometimes, the plugin load without fail and sometimes, we get the timeout error.

Viewing 1 replies (of 1 total)
  • Plugin Author Blog2Social-Support

    (@blog2socialsupport)

    Hello @joshualee55,

    thank you for your feedback. We are happy to hear that you like the UI and set up of Blog2Social. Furthermore, I am sure that we can get the plugin to work properly on your clients sites as well.

    First of all, Google+ is a tricky network when it comes to connecting third-party applications. If you are frequently asked to reset your password, please check whether you have the two-step-verification activated. In order to automatically post to google this setting should be deactivated. Please also try the following solutions.

    Solution 1: Please log in to your Google+ account and confirm possible confirmation-queries.

    Solution 2: Make sure that the two-factor authentication is deactivated. If you want to keep it activated for your account, you can create a new account and assign the admin role seperately (see: https://support.google.com/business/answer/4573962?hl=en)

    Solution 3: At first, please log in to your Google-Account on ‘Google Now’. Please go to the site: ‘unlock captcha (https://accounts.google.com/unlockcaptcha)’ Here you will find the security settings page for your Google+ Account. You are now being forwarded to a security query. By confirming the query, your account will be connected to our plugin after you got a note, that your access to Google+ is activated.

    Regarding the server timeout you are experiencing, could you specify which parameters you have increased? If the system requirements are fulfilled and the plugin is installed correctly, the following issues could lead to load spikes

    – The client is too slowly to process and load meta information, text or images in the time span given by the hoaster. Typically this timeout occurs after 30 seconds.
    Solution: Extend your timeout time to 40, 50 or 60 seconds in PHP settings.

    – You might not be using the most recent version of Blog2Social. The loading process was adapted in recent updates.
    Solution: Please update to Blog2Social 4.3.3

    – Your server might be using chaching, which was not installed through a wordpress plugin but instead activated through “nginx caching”. In general Blog2Social works fine with caching. However, issues might arise with wrong DNS settings : Error message 504 (Timeout)
    Solution: Please contact your hoster.

    – You might have activated a firewall, which interrupts outgoing connections.
    Solution: Please make sure your firewall allows Blog2Social or external websites such as social media networks to access and grab data from your website

    Please do not hesitate to contact us directly via email at customer-service(at)blog2social(dot)com we are always happy to help and glad to take a look at your site or one of your clients sites to fix the problems you’ve experienced.

    Looking forward to your reply and best regards.

Viewing 1 replies (of 1 total)
  • The topic ‘Good and yet problematic’ is closed to new replies.