WordPress.org

Forums

NS Cloner - Site Copier
Good (6 posts)

  1. kidcajes
    Member
    Posted 1 year ago #

    I like this plugin when using 3.6.1 but when I updated my WP to 3.9 suddenly this plugin no longer work. I encounter the WSOD (white screen of death). So I went to ftp and manually delete the ns folder and my site is back up again, and still I need this plugin to do the cloning of my subsites. But when I tried installing a new one directly for the plugins->add new it's just another WSOD. How can you help me with this? Is this compatible to 3.9? because the info says compatible to 3.6 only but then there are reviewers says it's working on higher version.

    Thanks and looking forward to hear from you guys!

  2. Never Settle
    Member
    Plugin Author

    Posted 1 year ago #

    We've tested on 3.9 and haven't had any issues so far. Is there any other info you can provide about your environment / hosting / etc. that could help us figure out what's going wrong on your setup? Are you getting WSOD just when you activate the Cloner? Are you seeing any errors in your PHP logs / other logs? Thank you for any other details you can provide.

  3. kidcajes
    Member
    Posted 1 year ago #

    Hi,

    My MultiSite settings is using SubDirectory. And the error occurs the moment I network activated the plugin and it gives me this:

    Notice: session_start() [function.session-start]: ps_files_cleanup_dir: opendir(/var/lib/php5) failed: Permission denied (13) in /xxx/wp/www/xxx/xxxx/wp-content/plugins/ns-cloner-site-copier/ns-cloner.php on line 77

  4. Never Settle
    Member
    Plugin Author

    Posted 1 year ago #

    It sounds like your PHP session folder (usually /tmp) is either:
    - not defined or
    - has the wrong permissions or
    - doesn't exist

    Or one of the solutions here might need to be implemented in your environment:

    http://vvv.tobiassjosten.net/php/php-session-garbage-collection/

    http://stackoverflow.com/questions/2904862/issues-with-php-5-3-and-sessions-folder

    PHP is generating a notice when the Cloner is trying to start a new session so there's probably something set not quite right for PHP sessions in your environment. If you aren't sure, you can also check with your host.

  5. kidcajes
    Member
    Posted 1 year ago #

    Ok I will try to contact them and will notify you. Thanks!

  6. Never Settle
    Member
    Plugin Author

    Posted 1 year ago #

    Sure thing, and if you hit a dead end there we will try to help however else we can. Cheers!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • NS Cloner - Site Copier
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.