WordPress.org

Support

Support » How-To and Troubleshooting » Gone a bit Pete Tong, its a mess

Gone a bit Pete Tong, its a mess

  • Hey guys,

    I have recently uploaded my wordpress site to its new host. I built the whole website locally where everything was on the http://localhost:8888/mysite/ address.

    After uploading my site I also uploaded the database. Wow the problems.

    – all of my main pages link back to the localhost
    – all post links go back there too
    – my password has changed to the old one which means I cant get onto my backend at all.

    This seems pretty major. I tried these lines in the functions.php but to no avail:

    update_option(‘siteurl’,’http://example.com/blog’);
    update_option(‘home’,’http://example.com/blog’);

    Has anyone encountered this?

    Please help

Viewing 15 replies - 1 through 15 (of 17 total)
  • And it has added extra pages that are not ment to be o the web version

    agh ! ! !

    Update your permalinks if you can access the Dashboard.
    Change/update links in the database in table WP Options if the old links are still there . You can search for the wrong links with a MySQL query and then replace using PHPMyadmin’s search function…
    Did you use absolute links?
    A live link would be useful…

    Hey Rhand,

    This is the live link http://www.coolkennogaa.com

    I have just seen your post so havent tried anything yet.

    Thanks for answering though

    In your source code:

    <style type=”text/css” media=”screen”>
    @import url(“http://localhost:8888/mysite/wp-content/themes/coolkennogaa/style.css”);
    </style>

    So the link is absolute and needs to be adjusted and you probably not adjusted your blog location in the Dashboard.
    You can access admin here:
    http://www.coolkennogaa.com/wp-login.php?redirect_to=http%3A%2F%2Fwww.coolkennogaa.com%2Fwp-admin%2F

    Try and change your blog location under settlings permalinks..

    But a few changes in the database using PHPMyadmin is quick and painless..

    ooooh, I changed the address in the settings.

    I am now completely shut out of the backend.

    This is not good.

    And my css file isnt attaching anymore

    Can you access PHPMyAdmin?

    Well, I guess you solved it. Enjoy your weekend!

    Sorry no i was out. just back but have to go again in 15mins.

    I can yes.

    Should I delete everything?

    Being good friday, had to pop around to the church and say hello

    I see. Yeah almost Easter..
    No, don’t delete anything yet. Just replace the wrong links in your database using phpmyadmin. You know the program, right? Link: http://www.phpmyadmin.net/home_page/index.php . Most hosts have it preinstalled for their clients to adjust MySQL dbases..

    To be honest I have only really began using it in the last few days to transfer files from my local to the host.

    I tink I have the programme with my MAMP programme on my local version: 2.11.7.1
    And on the host I have one too. version 2.11.3

    I dont know how to open the files with thi programme to look inside though.

    And should I go through everyone of them or is there just certain ones to change?

    PHPMyAdmin has a neat search function.
    I think you need to adjust most or all stuff in Table WP_Options. Check it and use browser function to easily see the links that are wrong.

    http://codex.wordpress.org/Changing_The_Site_URL

    From the list, look for wp_options. Note: The table prefix of wp_ may be different if you changed it when installing.

    Rhand thank you so so much for your advice,

    Unfortunately I have to tip off again, but I will work on it all night and hopefully get some results.

    I am thoroughly grateful for your time and I hope you dont think Im unthankfull and only here to be spoonfed.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Gone a bit Pete Tong, its a mess’ is closed to new replies.
Skip to toolbar