WordPress.org

Forums

going back to 1.2 from 1.3 (5 posts)

  1. aletheia
    Member
    Posted 10 years ago #

    I had upgraded to 1.3 and now I wanted to change to 1.2 mingus since all hacks and plugins are for 1.2
    It seems it doesn't like upgrade.php and upgrade-functions.php
    I'm getting big SQL errors.
    Maybe someone knows what's the issue? It's something to do with changing names and structure in the database...
    ´Warning: Invalid argument supplied for foreach() in /home/__/public_html/blog/wp-admin/upgrade-functions.php on line 59
    Database error: [You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'ADD post_status ENUM('publish','draft','private') NOT NULL' a]
    ALTER TABLE ADD post_status ENUM('publish','draft','private') NOT NULL
    ´
    Thanks

  2. Zarniwoop
    Member
    Posted 10 years ago #

    As fas as I know, upgrade means to change an older version to a newer one.
    I hope, you made a backup before going to 1.3 ;-)

  3. aletheia
    Member
    Posted 10 years ago #

    funny isn't it?
    well, I downloaded the latest nightly (june) and didn't realize it was 1.3 (had been doing this for all nightlys of may). I should have downloaded from the sourceforge page instead.
    No problem about 1.3 it works fine, except that I'm finding the differences are important for pluggins and hacks.
    No, I didn't make a database backup. Not important since the blog is new.
    Just want to know if the problem is that the table structures are really different or it's just the files because it's a whole different story.

  4. Beel
    Member
    Posted 10 years ago #

    There has been a lot of discussion about why plugins were not working for 1.3 and recently those changes in 1.3 were fixed. All my plugins are currently working in 1.3 so you may want to try a newer nightly (or of course go back to 1.2 before the blog is not so new ;-)

  5. aletheia
    Member
    Posted 10 years ago #

    I guess it's not a big problem. As you say most plugins work correctly.
    I was trying to use the polls hack this morning and that's where I ran into the issue.
    ... too bad.. patience ;-)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.