Support » Fixing WordPress » GoDaddy Managed WordPress site preloading non-existent CSS and JS

  • Resolved aartitendulkar

    (@aartitendulkar)


    A GoDaddy Managed WordPress website I am working on is appearing broken. I can see the following two errors on the Chrome Developer Console:

    Refused to apply style from ‘<domain_name>/wp-content/cache/min/1/0cab974183f9d7100c323c742034baaf.css’ because its MIME type (‘text/html’) is not a supported stylesheet MIME type, and strict MIME checking is enabled.
    GET <domain_name>/wp-content/cache/min/1/022f8c17c96cac48b70f2cd6d31de451.js net::ERR_ABORTED 404 (Not Found)
    I have checked the wp-content/cache/min/1 folder via SFTP. These two CSS and JS files do not exist.

    However, I can see these nodes in “Elements” in the developer console: In the <head> tag

    <link rel=”preload” href=”<domain_name>/wp-content/cache/min/1/0cab974183f9d7100c323c742034baaf.css” as=”style” onload=”this.onload=null;this.rel=’stylesheet'” data-minify=”1″>
    Towards the end of the <body> tag:

    <script src=”<domain_name>/wp-content/cache/min/1/022f8c17c96cac48b70f2cd6d31de451.js” data-minify=”1″ defer=””></script>
    <noscript><link rel=”stylesheet” href=”<domain_name>/wp-content/cache/min/1/0cab974183f9d7100c323c742034baaf.css” data-minify=”1″ /></noscript>
    Could anyone please tell me where these nodes could be getting generated from?

    P.S. I am using the WP Rocket plugin on this website. I had previously also used the Autoptimize plugin, but it is now deleted. However some of its files can still be seen via SFTP.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Optimizing Matters

    (@optimizingmatters)

    Maybe try clearing GoDaddy’s page cache?

    re. Autoptimize’s cache; that’s irrelevant for the rest of your question, but feel free to delete the autoptimize directory in wp-content/cache if you have removed AO.

    frank (ao dev)

    aartitendulkar

    (@aartitendulkar)

    Yes, I’ve cleared GoDaddy’s cache, WP Rocket’s cache, purged WP Rocket OPcache and regenerated the critical path CSS, to no avail.

    Also deleted the autoptimize cache (not that I feel that could be a problem), but no luck.

    Optimizing Matters

    (@optimizingmatters)

    hmm … do you also use Cloudflare maybe? and if all else fails disable JS/ CSS minify in WP Rocket?

    aartitendulkar

    (@aartitendulkar)

    No, I’m not using Cloudflare, though I did use it before. Disabling CSS/JS minify in WP Rocket hasn’t worked either.

    Optimizing Matters

    (@optimizingmatters)

    when you disable CSS/JS minify, you still see references to the minified CSS/JS? in that case this seems like a stale entry in the page cache of either WP Rocket or Godaddy really.

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    Moved to Fixing WordPress, this is not a Developing with WordPress topic.

    aartitendulkar

    (@aartitendulkar)

    @optimizingmatters firstly, thanks for trying to help! Really appreciate it!

    I manually deleted wp-rocket cache files, then deactivated WP Rocket. But I could still see references to the minified CSS and JS files. So I too think there might be stale entries in GoDaddy’s cache.

    Could you please tell me how I can confirm this, and how I can remove them?

    Optimizing Matters

    (@optimizingmatters)

    Generally stale cache can be confirmed by adding a random attribute+value to the querystring, e.g.

    https://yoursite.com/?bust-cache=12345OIKS

    (Although some caches ignore those)

    Not familiar with GoDaddy I’m afraid, best to refer to their support?

    aartitendulkar

    (@aartitendulkar)

    Confirmed that a stale cache is being served by adding a query string as suggested. Will refer to GoDaddy support to resolve this.

    @optimizingmatters Thank you for your help!

    Optimizing Matters

    (@optimizingmatters)

    you’re welcome, if you ever want to get the most of Autoptimize (combined with WP Rocket) you know where to find me 😉

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.