WordPress.org

Ready to get started?Download WordPress

Forums

GoDaddy (19 posts)

  1. JenFernandez
    Member
    Posted 6 years ago #

    I am trying to self install wordpress on my GoDaddy hosting account. I am getting an error establishing a database connection. I am pretty sure I have the wrong hostname, but I can't figure out where to find the right one. Any help would be greatly appreciated. Thanks.
    Jen

  2. VeraBass
    Member
    Posted 6 years ago #

    Call them and ask for the name of the server you are on. That's what you need to replace 'localhost' with.

    You can also find it in your account somewhere ...I think you follow 'manage hosting accounts'.

  3. JenFernandez
    Member
    Posted 6 years ago #

    Nevermind, I found it. =)

  4. adriannye
    Member
    Posted 6 years ago #

    Cummon people, help the next poor sucker
    by explaining how you fixed things.

    Here is how you find the server name at godaddy:

    1. log in to hosting account (different from domain name account)
    2. open control panel (link to the right of your
    domain name)
    3. click on databases
    4. you should see a MySQL database there, if you
    don't you need to create one for wordpress. Click on it.
    5. click on the little pencil button near the right.
    6. your server name is listed. Mine is p42mysql207.secureserver.net. You need all of it.
    7. DO NOT click on "Open Manager" since the info
    is not in there.
    8. replace "localhost" with that server name

    Now continue with wordpress directions. Why they don't
    put this info in the install instructions I don't know.

    I should add one more thing. When you create a database
    at godaddy it is pretty much instant, but their lingo
    is confusing. For the hosting account as a whole,
    a status of "Setup" means your account is not ready yet. For example, if you switch from Windows to Linux it can take 3 days to get out of Setup to where you can use your account.

    But in the case of databases, "Setup" means ready to use.
    I think a word like "Ready" would be better.

  5. MichaelH
    Member
    Posted 6 years ago #

    @adriannye - at your behest, added a link to the section on Installing WordPress, Step 3 - setting up wp-config.php to point to Possible DB_HOST values.

    Please note the usage of the word 'possible' there. Each time you create a database at Godaddy, that database could be created on a different database host. Currently the 4.1 and 5.0 databases also cause a different set of server/DB_HOST values to be used.

  6. deloresdefacto
    Member
    Posted 6 years ago #

    Here's what's wrong with my GoDaddy domain hosting. I'm getting the "Your PHP installation appears to be missing the MySQL which is required for WordPress." What the heck is this about. I've worked with WordPress on different hosts for a while and I've never received this message. I created a SQL database with my GoDaddy host manager to see if this is the problem. I've cut and paste my sql backup files to conform to their 2MB file size requirements and yet I still can't get my site back up.
    Anyone else have major issues with GoDaddy like this?

    Thanks.

  7. Jeremy Clark
    Moderator
    Posted 6 years ago #

    It means that they haven't setup the server correctly. You'll need to call and tell them the error as there is nothing you can do about it.

  8. deloresdefacto
    Member
    Posted 6 years ago #

    Thanks a bunch. I contacted the support staff in email because they had been helping me with uploading the database backup files.

  9. Adam Brown
    Member
    Posted 6 years ago #

    [jeremy beat me to it]

  10. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    For reference, this will happen only on the dedicated or virtual dedicated server packages with GoDaddy, I think. That's because you get your own machine (sorta) to yourself, to setup as you see fit.

  11. Stalker1108
    Member
    Posted 6 years ago #

    I was frustrated to the point of tears trying to set WordPress up. Thank you jeremyclark13. Not that I will get them to fix it. Worst customer service ever.

  12. deloresdefacto
    Member
    Posted 6 years ago #

    The problem was a difference in a Windows hosting package and a Linxus hosting package. I had to update to Linxus so the PHP capability was enabled. Now I know! Thanks again.

  13. bryanmcclure
    Member
    Posted 5 years ago #

    In the fourth post adriannye states to change your localhost to the server name.

    I have 2 questions about this, is the "server name" the same as "Host Name"? And how do I go about changing localhost to that name? I don't see localhost listed.

    I see the following:
    MySQL Database Information
    Status: Setup
    Host Name: long name
    Database Name: my username
    Database Version: 5.0
    Description: WordPress
    User Name: my username

    Can someone help me? Thanks

  14. MichaelH
    Member
    Posted 5 years ago #

    DB_HOST would be set to your Host Name that is typically something like h41mysql52.secureserver.net

  15. thisisedie
    Member
    Posted 5 years ago #

    @Stalker1108

    Worst customer service ever

    You mean Godaddy? I've had nothing but excellent service from them for many years.

    @bryanmcclure

    I don't see localhost listed.

    You change it in your wp-config.php file and then upload it.

  16. barbarahoward
    Member
    Posted 5 years ago #

    Hello - when I reach the step 5 for installing the script, I get a blank screen. Now what?

    signed,
    Pulling my hair out in oHIo

  17. robbell
    Member
    Posted 5 years ago #

    You can install wordpress on Godaddy using the 'Hosting Connection' applications list - then GD does it automatically for you.

  18. barbarahoward
    Member
    Posted 5 years ago #

    Thank you!

  19. WebDev WaxLotus LLC
    Member
    Posted 5 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic