Support » Plugin: amr ical events lists » Go-to-date button just goes to Home page

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author anmari

    (@anmari)

    HI,

    Sounds like you have something messing with your urls or with your php $_GET variable, or your form action.

    It’s just a form with a method that should point back to the same page that the shortcode is on. It picks up the month selected and passes it, just like one could with a link.

    Like here:
    http://test.icalevents.com/large-box-calendar/largecalendar/?start=20170201

    If you do ‘inspect element’ around the dropdown and button area, and then look up till you see the FORM html, you can check what is in the ‘action=’ part of the form. It should be the same page that you are on.

    Plugin Author anmari

    (@anmari)

    By the way, to do wordpress tags one should comma separate them, else it’s all just one big tag 😉

    Hi anmari,
    Many thanks for your quick feedback.

    Inspecting the Form element, I can see that:
    action=”http://www.mySite.org.uk/?page_id=4305&listtype=9″

    This looks correct to me. Again, my shortcode is on:
    http://www.mySite.org.uk/?page_id=4305

    I don’t know what else to look at to get the button working correctly.

    Plugin Author anmari

    (@anmari)

    Hi Tim,
    sorry about delay in replying, I’m travelling.

    Sounds like something is interfering with the _GET variable on your system, since it’s okay on other systems.

    You could try setting permalinks BUT I think you may have to do the usual painful debugging
    http://webdesign.anmari.com/2932/debugging-a-possible-clash-between-plugins-andor-a-theme/

    timhuk

    (@timhuk)

    Many thanks anmari,

    For now I have removed the drop-down list of months and “Go to date” button, to hide the problem. I will follow your debugging advice when I have more time and let you know if I come up with anything.

    Cheers

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Go-to-date button just goes to Home page’ is closed to new replies.