Support » Plugin: Easy WP SMTP » Gmail SMTP is NOT working

  • I have tried for 2 hours, but always get the following error – trying to use gmail as the smtp set up. I tried other servers and it worked fine, but gmail will not work.

    One thing I Noticed is that when I pasted in my password, as soon as I hit save and it renders, the area with the pw showing ********** shows many more characters than my pw. Is that legit?

    In any event, this is severely frustrating as I have used this plugin with other servers just fine and it says it works with gmail. What gives? Thanks.

    ERROR:

    CLIENT -> SERVER: EHLO xxxxxxxx.com
    CLIENT -> SERVER: STARTTLS
    CLIENT -> SERVER: EHLO xxxxxxxx.com
    CLIENT -> SERVER: AUTH LOGIN
    CLIENT -> SERVER: ZHJha2Vmb3JtQGdtYWlsLmNvbQ==
    CLIENT -> SERVER: e3kuflwiQDpGZStiNFhDZ2M=
    SMTP ERROR: Password command failed: 535-5.7.8 Username and Password not accepted. Learn more at
    535 5.7.8 https://support.google.com/mail/?p=BadCredentials c15sm4126942iob.67 – gsmtp
    SMTP Error: Could not authenticate.CLIENT -> SERVER: QUIT
    SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Contributor Alexander C.

    (@alexanderfoxc)

    Hi @yesyeah.

    The plugin works with Gmail just fine, I’m personally using it on my own websites.

    Which SMTP settings are you using for Gmail (host, port, encryption)?

    Also, are you entering your full Gmail email in the username field? It should be youremail@gmail.com (including the @gmail.com part).

    • This reply was modified 2 years, 1 month ago by Alexander C..

    I set it up exactly as it is here:
    https://wp-ecommerce.net/easy-wordpress-smtp-send-emails-from-your-wordpress-site-using-a-smtp-server-2197

    smtp.gmail.com
    465 ssl / 587 tls (Tried both)
    username: full email address

    I set this up exactly as it states.

    • This reply was modified 2 years, 1 month ago by yesyeah.

    NO clue why it didn’t work but it may have had to do with the contact form. I swapped that out and just removed the plugin and moved forward. Thanks for the help.

    Plugin Contributor Alexander C.

    (@alexanderfoxc)

    Hi @yesyeah, sorry for late reply, been busy with some offline stuff.

    Have you tried some other SMTP plugin? I don’t think the issue is plugin-related, but rather some other issue. In order to confirm that, can you try to test your SMTP settings with other plugin on your server and let me know the results? I can’t name you any, but you can easily find one in WP plugins directory 😉

    I can’t get it working either.

    First I got a “less secure app” error, and accompanying email alerts to my account, and then after disabling that in my Google settings, I got the same “SMTP ERROR: Password command failed” issue as the OP, with no seeming way to get it working.

    I have configured this plugin with virtually every mail server I have access to, with no problems, but no way Gmail was accepting anything. It’s likely a problem with my password (I have special characters for security) but it’s way way too much time to troubleshoot.

    It could an error checking the certificate. I had the same problem and disabling validating certificate in php solved the problem.

    More than likely the issue is that you have two factor authentication turned on in your email account.
    To fix it, login to gmail, go to
    https://security.google.com/settings/security/apppasswords
    Where it says ‘Select App’ choose ‘Custom’. You’ll have to choose a name, I chose WordPress SMTP, as it was descriptive, and then press ‘Generate password’. This should kick out a 16 letter password for you. Copy that password, and place it where your password would be in the SMTP Password section where your email password would normally go.

    • This reply was modified 2 years, 1 month ago by troblems. Reason: More details
    Plugin Contributor Alexander C.

    (@alexanderfoxc)

    Hey @troblems, thanks a bunch for this instruction! If you don’t mind, I might use a slightly modified version of it on the settings page to help users fix potential Gmail SMTP issues.

    @slango, thank you for your report. Could you let me know which special chars are you using in your password? I suspect there is a bug related to passwords with special chars and your reply could help me troubleshoot it.

    freakybigfoot

    (@freakybigfoot)

    Ya I’m having an issue as well. Everything was working fine but then I started getting this error: ssl3_get_server_certificate:certificate verify failed

    I’m running on a windows server. What cert am I supposed to update exactly?

    Was this ever resolved? I ran into it YET again. And it looks like many others have the same issue.

    Super frustrating.

    Plugin Contributor Alexander C.

    (@alexanderfoxc)

    It was fixed, there was an issue with special characters in passwords.

    Are you still having issues? Can you provide some details? If we don’t know what the issue it, we can’t fix it, unfortunately.

    I’m the original poster of this thread. Is there a link to how the gmail set up should work now? Optimal settings? Cause it’s still not working for me.

    I am using the correct gmail address and password.
    I am using smtp.gmail.com on port 465 SSL
    I have checked to allow use of less secure pasword.

    Please advise, thanks!
    —-

    CLIENT -> SERVER: EHLO DOMAINNAME.com
    CLIENT -> SERVER: AUTH LOGIN
    CLIENT -> SERVER: d2Vnb2NvbnRhY3Rmb3JtQGdtYWlsLmNvbQ==
    CLIENT -> SERVER: VzNHMGZvUm1zMzIxIQ==
    SMTP ERROR: Password command failed: 534-5.7.14 <https://accounts.google.com/signin/continue?sarp=1&scc=1&plt=AKgnsbt7
    534-5.7.14 emM4_3fOnQ5m5QuvSD7ATs7wb2NnDfoR8si6fO7ngwB33k8ejwW2Q60l4gwxzo4K6fctp4
    534-5.7.14 erdJaCbD3dr3iIlpVDXM8crjFEZlqEYuarI3pdf2xhdmhXz1zMp4RFvVAD-pmzUGyK4Ngu
    534-5.7.14 SDC0_JhxRiBBtiiXAfWbVX1xIUJRXyC0D6kw5JTYCRO-_lJ4g0YOFwVw7I2corhjT75qAB
    534-5.7.14 YMOxE_zLp3umfF-dLXG88KQzuK1fk> Please log in via your web browser and
    534-5.7.14 then try again.
    534-5.7.14 Learn more at
    534 5.7.14 https://support.google.com/mail/answer/78754 z18sm3362026iti.30 – gsmtp
    SMTP Error: Could not authenticate.CLIENT -> SERVER: QUIT
    SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

    Plugin Contributor Alexander C.

    (@alexanderfoxc)

    Thank you for the log. As you might have noticed, your original log was saying your credentials are incorrect. This was because your password has some special characters and the plugin had difficulties in handling them then. But now it has been fixed.

    Your new log doesn’t say your credentials are incorrect, it says “Please log in via your web browser and then try again”. Also it has some useful links right in it. For instance, this one: https://support.google.com/mail/answer/7126229?visit_id=1-636555155180707818-2829240065&rd=2#cantsignin . I guess your problem might be in this: https://support.google.com/accounts/answer/6010255

    Thanks for your quick response.

    Yes, sadly, that was already done. Less secure apps are allowed. 2 step verification off. Not sure what else to do.

    Plugin Contributor Alexander C.

    (@alexanderfoxc)

    1. Have you tried this one as well? https://accounts.google.com/b/0/DisplayUnlockCaptcha

    2. Have you tried other SMTP plugins? If no, can you try and let me know the results?

    3. Do you have some special or non-English chars in your password? Like UTF, Cyrillic, Chinese or some language-specific symbols like umlauts etc. If you do, please let me know those, I’m gonna update my gmail password with these chars and test the plugin. If you feel uncomfortable providing such information publicly, you can email me personally at fox@stripe-plugins.com .

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Gmail SMTP is NOT working’ is closed to new replies.