Support » Plugin: WP Mail SMTP by WPForms » GMAIL "SMTP Error: Could not authenticate"

  • jules.maas

    (@julesmaas-1)


    Argh. wp_mail is not sending ANY email via the WP-Members app required for a restricted section of my website. I activated this plugin to fix that problem, but EVERY TIME I try to send a test email to my personal email address (jules.maas@gmail.com) I get this error: “SMTP Error: Could not authenticate”

    I’ve filled out all the fields as follows:

    From Email: nwamotc@gmail.com
    From Name: NWAMOTC Webmaster
    Mailer: Send all WordPress emails via SMTP
    Return Path: Set the return-path to match the From Email (checked)

    SMTP Host: smtp.gmail.com
    SMTP Port: 465
    Encryption: None (If I select SSL or TLS, I get THIS error: https://support.google.com/mail/answer/14257)

    Username: nwamotc@gmail.com
    Password: ******** (current & correct password)

    https://wordpress.org/plugins/wp-mail-smtp/

Viewing 14 replies - 16 through 29 (of 29 total)
  • Chris yes, I like it and use Mandrill for all my websites.
    Anyway I prefer to use this SMTP plugin instead of wpmandrill, always prefer something lightweight.

    Hi – Yeah – haha – I did read about it. I still couldn’t figure out it’s purpose. It sends emails. But I have mailchimp that does that for marketing and gmail for interactions and that’s all I send – except for those few that send from my website. And the SMTP issues I have ARE from sending emails from my website, which my host forbids via smtp for some stupid reason. And unfortunately, changing any time soon is out of the question.
    If I could see a way through Mandrill to send the way I’d like, but their website is very glyphic. How would I get around the host – and still send emails ‘from’ my domain? It doesn’t say anything like that. And also says get a developer before starting. haha
    Any way – this plugin doens’t work for me at all. I had to dump it and the (purchased) scheduling plugin that relied on stopping the goofy ‘from’ address: wordpress@mydomain.com – this after hours of fighting with it – and my host. Good luck. 🙂

    Chris you’re using Google Apps? Try this.

    Yeah thanks – I tried that too. Got everything set up correctly until it told me my host was blocking the outgoing smtp ports – ALL OF THEM – and then it could help no more. Highly recommended though. Thanks for the help!

    Oh no! Yup that’s a problem. But you just gave me an idea — sending mail to Gmail via the Gmail API. There’s no way your host could ALSO be blocking the HTTP/HTTPS port..

    Yeah – that would be ideal!

    wordpress latest version 4.1.1 not supported any smtp plugin

    @himanshu_ag, I don’t think that’s true

    Chris, it’s done.

    @jason Hendriks you are right.A little changes in settings, under mailer section i had selected Use the PHP mail() function to send emails. currently my plugin is working properly http://bit.ly/17ZJWWA

    @himanshu_ag if you select Use the PHP mail function you are not using SMTP.

    Well, technically PHP Mail has to use SMTP, because SMTP is the only protocol for moving mail on the Internet. PHP Mail just assumes there is an SMTP server installed on localhost at port 25. If there is no server… it can’t work.

    For Games

    (@sockscap64)

    Hello, This is SocksCap64.
    I got this error too and now it’s works fine.
    record here may help the other people meet this error.

    1, open https://myaccount.google.com/
    at the tab ‘Signing in’ you will find ‘Access for less secure apps’ is turn off.
    change it to ‘turn on’

    2, open https://accounts.google.com/DisplayUnlockCaptcha
    it’s will response:

    Account access enabled
    Please try signing in to your Google account again from your new device or application.

    the problem is resolved.

    For Games

    (@sockscap64)

    Correction: as @jason Hendriks’s reply, my solution reduce my security, so the better choice is use OAuth 2.0.
    https://wordpress.org/plugins/postman-smtp/

    i already installed this plugin, and it’s working fine.

    the configure has a bit inconvenient( need to create a new project at GAE ).

Viewing 14 replies - 16 through 29 (of 29 total)
  • The topic ‘GMAIL "SMTP Error: Could not authenticate"’ is closed to new replies.