Support » Plugin: WP Mail SMTP by WPForms » GMAIL "SMTP Error: Could not authenticate"

  • Argh. wp_mail is not sending ANY email via the WP-Members app required for a restricted section of my website. I activated this plugin to fix that problem, but EVERY TIME I try to send a test email to my personal email address (jules.maas@gmail.com) I get this error: “SMTP Error: Could not authenticate”

    I’ve filled out all the fields as follows:

    From Email: nwamotc@gmail.com
    From Name: NWAMOTC Webmaster
    Mailer: Send all WordPress emails via SMTP
    Return Path: Set the return-path to match the From Email (checked)

    SMTP Host: smtp.gmail.com
    SMTP Port: 465
    Encryption: None (If I select SSL or TLS, I get THIS error: https://support.google.com/mail/answer/14257)

    Username: nwamotc@gmail.com
    Password: ******** (current & correct password)

    https://wordpress.org/plugins/wp-mail-smtp/

Viewing 15 replies - 1 through 15 (of 29 total)
  • oh, here’s some extra info:

    The SMTP debugging output is shown below:
    SMTP -> get_lines(): $data was “”

    SMTP -> get_lines(): $str is “”

    SMTP -> get_lines(): $data is “”

    SMTP -> get_lines(): timed-out (10 seconds)
    SMTP -> FROM SERVER:

    SMTP -> get_lines(): $data was “”

    SMTP -> get_lines(): $str is “”

    SMTP -> get_lines(): $data is “”

    SMTP -> FROM SERVER:

    SMTP -> ERROR: EHLO not accepted from server:

    SMTP -> FROM SERVER:

    SMTP -> ERROR: HELO not accepted from server:

    SMTP -> ERROR: AUTH not accepted from server:

    SMTP -> NOTICE:
    EOF caught while checking if connected

    I was able to get it to work, using a Gmail account. Here are the relevant settings:

    Mailer: Send all WordPress emails via SMTP.
    SMTP Host: smtp.gmail.com
    SMTP Port: 587
    Encryption: Use TLS encryption.
    Authentication: Yes: Use SMTP authentication.
    Username: [your – entire – Gmail or Google Apps email address]
    Password: [your password for your Gmail or Google Apps email account]

    ajaysolskjaer

    (@ajaysolskjaer)

    Do we need to make any change in MX entry?
    I cant connect using neither 465 nor 587. I tried all possible options.

    Still it says
    Boolean (false) &
    “SMTP Error: Could not authenticate”

    Any solution? Can you give me a detailed view.
    I am using xyz@gmail.com…. not xyz@mydomain.com. i.e gmail account itself

    Thanks

    mcbsys

    (@mcbsys)

    Some hosts do not allow outbound connections on 587. I blogged about how to test it: http://www.mcbsys.com/techblog/2014/12/testing-an-outbound-port-from-your-web-host/.

    “SMTP Error: Could not authenticate” is not a connectivity issue. He’s already connected.

    Jason, I was responding to the ajaysolskjaer’s statement, “I cant connect using neither 465 nor 587.” But you’re right, the actual error message indicates it’s not a connection issue but an authentication issue.

    I also had problem with authentication with my gmail and the reason was gmail wanted phone number because “We’ve detected unusual activity on your account. To sign in, please follow the instructions below. Provide a phone number to continue. We’ll send a verification code you can use to sign in.”. Unusual activity was sending mails from wordpress.

    I get the same error. I’m using a Google Apps account and I have tried every combination. I even tried to go back to gmail and log in using the creds I was inserting to make sure I was using correct ones or they hadn’t expired or something.
    Nothing works.
    Any ideas?

    I also tried a non-google-apps regular gmail account and got the same results. It does not allow this to work.

    Same error at bottom each time:
    SMTP -> ERROR: Failed to connect to server: Connection refused (111)
    I have verified all settings and double checked credentials.

    Help! 🙂

    I tried everything too. Finally switched to free Mandrill. Problem solved.

    I have Mailchimp but don’t understand Mandrill at all… 🙂

    Try this: https://support.google.com/mail/answer/78754

    I did this and it seems to be working now:
    If you’re still having problems, visit http://www.google.com/accounts/DisplayUnlockCaptcha and sign in with your Gmail username and password. If necessary, enter the letters in the distorted picture.

    If not try going through the entire list, that should solve your issue, hopefully. 🙂

    Google has been increasing their security. Access Gmail with OAuth 2.0 or you’re going have to jump through hoops like @elvinong pointed out; application-specific passwords, two-factor authentication, Captcha, and enabling less secure apps as an account setting

    Chris so read about it 🙂 Mandrill is really good way of sending emails from your website. Much better solution than fight with regular email such as gmail …

    Peter, it’s worked flawlessly so far and I think I can stay under the 12,000 limit on the free plan :). And they have a plugin.

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘GMAIL "SMTP Error: Could not authenticate"’ is closed to new replies.