Support » Plugin: WP Gmail SMTP » Gmail no longer accepting to send emails

  • Resolved michelne

    (@michelne)


    I installed Gmail SMTP plugin a couple of years ago and it worked fine until recently.
    The current situation is:
    * The plugin SMTP status is “Connected” (green)
    * When sending a test email I get:
    2020-12-03 15:32:52 SMTP ERROR: AUTH command failed: 334
    (I’m only indicating the key line.)
    Therefore I proceeded to console.developers.google.com in order to find out what the problem is. Everything was normal until I got I checked the “OAuth consent screen”. This screen informed me that “Verification status” is “Needs verification”. I started the verification process but quickly discovered it requires a google approval which (according to the google help) can take 4 to 6 weeks!
    I searched online for a solution and found the following:
    https://wordpress.org/support/topic/gmail-email-submit-your-app-for-restricted-scopes-oauth-verification/
    It informed me that I have to set the “User type” to “Internal” instead of “External”.
    I checked the “OAuth consent screen” and sure enough “User type” was set to “External”.
    I tried to change it but received a message that only GSuite users can set it to “Internal”.
    Therefore, I tried to create a new project to restart from scratch. But once I reached the “OAuth consent screen” of the new project it asked me:
    “Choose how you want to configure and register your app, including your target users. You can only associate one app with your project. ”
    The options were: “Internal” and “external”. The “Internal” option was greyed out and reserved for Gsuite users (according to the help).
    How can I get the plugin working again?
    Any assistance would be much appreciated.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Noor Alam

    (@naa986)

    @michelne, It doesn’t need to be “Internal”. Please follow these instructions to try a fresh authorization and see what happens:

    https://wphowto.net/gmail-smtp-plugin-for-wordpress-1341

    Thread Starter michelne

    (@michelne)

    Hello Noor,
    I created a new project and followed the above instructions. It didn’t work but I was able to fix it as described below.

    High-level summary: the issues were that firstly the plugin still thought it was connected. This was fixed by deleting the app key. Secondly, google created several new restrictions on Oauth apps, which I had to address.

    More details:
    1. When I reached the corresponding step in the instructions, the “Grant Permission” button failed to appear as expected. To fix this, I had to go to press on the button under: App Settings -> Revoke access -> Delete app keys
    2. When I pressed the “Grant Permission” button and logged in on the consent screen, Google informed me that I was not an authorized user of the app. I fixed this by (in the google console) going to “Oauth consent screen” and under “Test users” clicking “Add user”. I then added the email corresponding to my google account.
    3. Google then made me pass through a screen warning me that the app was unsafe. I had to click on a tiny almost invisible link (“Proceed” or “advanced” I don’t remember) in order to move on to the next screen.
    4. The above fixes were enough to make it work on one of my wordpress sites, but I have a second one. It turns out that the same key can’t be used on two different sites. When I created a new key under the same project everything worked.

    PS Credentials/App Creation Step 6 has changed a bit: more fields, and now some additional fields (e.g. developer email) are mandatory.

    Plugin Author Noor Alam

    (@naa986)

    @michelne, Thank you so much for sharing this. I wasn’t aware of these changes.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.