Support » Plugin: WP Mail SMTP by WPForms » Gmail Free + SPF, DKIM, DMARC error/warning notification

  • Resolved mvenkadesan

    (@mvenkadesan)


    Hi,

    I am using WP Mail SMTP and set things up according to your instructions for the Gmail API to send email using my free Gmail API. However, I receive an error message about SPF and two warning notes about DKIM and DMARC now. I did not receive these messages previously. The SPF error message says,

    SPF
    Action Needed: It doesn’t look like the SPF record required by Google has been added to your domain. Please check out Google’s SPF guide for details on how to add this record to your domain’s DNS.

    Do I need to add a new TXT record to my DNS settings? I use Google Domains. If so, what should it include? Any help will be much appreciated. I don’t want my customers to stop receiving email, and I am afraid that might be the case now.

    Thank you!

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Gregor Capuder

    (@capuderg)

    Hi @mvenkadesan,

    are you using a custom domain (not @gmail.com) for your From Email address in our plugin? Are you using a Gmail account with a custom domain alias?

    Take care!

    Thread Starter mvenkadesan

    (@mvenkadesan)

    Hi @capuderg : thanks for the response. I am using a custom domain for my “From Email” address in your plugin. My Gmail account is the free one, so just gmail.com.

    Hi @capuderg, I have the same issue as @mvenkadesan!

    When I send a test email, the email is sent through and received, but it shows the following messages:
    ——————————————————————
    Domain Check Results
    SPF
    Action Needed: It doesn’t look like the SPF record required by Google has been added to your domain. Please check out Google’s SPF guide for details on how to add this record to your domain’s DNS.

    DKIM
    Action Needed: It doesn’t look like the DKIM record required by Google has been added to your domain. Please check out Google’s DKIM guide for details on how to add this record to your domain’s DNS.

    DMARC
    Action Recommended: It doesn’t look like DMARC has been set up on your domain (<domain-name>). We recommend using the DMARC protocol because it helps protect your domain from unauthorized use. Please check out our step by step guide for details on how to add this record to your domain’s DNS.
    ——————————————————————

    My setup is as follows:
    * Bitnami WordPress stack hosted on Google Cloud Platform
    * Domain registrar: Google Domains
    * Using a free Gmail address as the connection to Gmail.
    * Using with an email forwarding set up to the Gmail address with a domain address: contact@<domain-name>.
    * The error and warnings show up *only* when the “From Email” is set to use the forwarding address, with “Force From Email” selected
    * When using just the free Gmail address, there are no issues or messages.

    It seems that the issue *may* be because Google is trying to find the records expecting the DNS settings for a Google Workspace domain when it encounters the domain forwarded email, but I am not using Google Workspace. Could that be the case?

    I haven’t tried it yet, but have a sneaky suspicion that using another provider like Sendinblue *might* resolve the issue?

    Any help will be very much appreciated.

    Many thanks,
    Rupak

    Plugin Author Gregor Capuder

    (@capuderg)

    Hi @mvenkadesan and @rupaksinha,

    please ignore the Domain Check Results section in the Email Test tab for now. Our Domain Check system is not excepting the free gmail.com accounts with custom domain from emails (it is currently showing you the suggestions for G-suite/Workspace).

    We will try to resolve this issue for the next plugin update. For now, you can just ignore that section. The emails are sending just OK, right?

    Take care!

    Thread Starter mvenkadesan

    (@mvenkadesan)

    @capuderg : emails are being sent correctly for me.

    I am using Google Workspace with my custom domain email address. I am getting the following error:

    spf
    Action Needed: It doesn’t look like the SPF record required by Google has been added to your domain. Please check out Google’s SPF guide for details on how to add this record to your domain’s DNS.

    Google’s SPF guide in Step 1: Create your TXT record for SPF, is asking for the third-party mail server’s IP address and domain names.

    I have seen in several posts here that show the reluctance by WP Mail SMTP to provide SPF values to add to the DNS records. Although these emails are being sent out, there’s not guarantee that they won’t be flagges as spam.

    Plugin Author Gregor Capuder

    (@capuderg)

    Hi @mrbagpipe,

    all emails are actually sent from the Google servers, so you should just start with the “Step 1: Create your TXT record for SPF”, so the SPF record you need to add to your domain’s DNS is v=spf1 include:_spf.google.com ~all.

    Keep in mind, that if you have multiple SPF records defined for your domain, you’ll have to merge them into one SPF record. More info here.

    Have a nice day!

    • This reply was modified 1 month, 3 weeks ago by Gregor Capuder. Reason: Added multiple SPF records link
    Thread Starter mvenkadesan

    (@mvenkadesan)

    @capuderg : I saw that there was an update to the WP Mail SMTP plugin. Did this update fix the SPF record issue for Gmail Free?

    Plugin Author Gregor Capuder

    (@capuderg)

    Hi @mvenkadesan,

    no, the free Gmail with custom from email domains will still display the DNS suggestions, which should be ignored for now.

    We’ll try to resolve this in the next plugin version.

    Have a nice day!

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.