Support » Plugin: WP Mail SMTP by WPForms » Gmail: email “Submit your app for Restricted Scopes OAuth verification”

  • Plugin Author Slava Abakumov

    (@slaffik)


    Those, who are using Gmail mailer to send emails, might have started receiving this email from Google Apps Developers <noreply-apps-developer@google.com>: [Action Required] Submit your app(s) for Restricted Scopes OAuth verification

    First of all, don’t panic.
    Secondly, it’s an easy fix, and you don’t need to send the app you created for Gmail integration for the verification.
    Reason: you are using this app internally to send emails on your behalf.

    What should you do?

    TL;DR: http://cloud.supportally.com/8a1aa0559a67

    1. Go to this page: https://console.developers.google.com/apis/credentials
    2. Make sure that in the header you see selected the project, that you created when you configured Gmail API to send emails
    3. Open Credentials > OAuth consent screen tab at the top of the page: http://cloud.supportally.com/246a0a654773
    4. In Application type select “Internal” radio button: http://cloud.supportally.com/8a1aa0559a67
    5. Click “Save” button at the bottom of the page

    That’s all. All Verification related notices on that page will disappear and everything should continue working as it used to be.

Viewing 8 replies - 1 through 8 (of 8 total)
  • I use Gmail in the plugin and am having issues with this new verification process. I tried following your instructions above, but my screen looks different.

    https://fpmt.org/smtp.PNG

    I don’t have the public / internal options.

    Please disregard my previous message. I was able to fix the issue myself. Thank you.

    Please disregard my previous message. I was able to fix the issue myself. Thank you.

    @fpmtinc Could you please tell how you fixed this? Having the same issue.

    • This reply was modified 1 year, 9 months ago by bluzilla.

    I fixed this by following Slava’s instructions above. Originally I did not have the option to select the Application Type as Internal, which fixes the problem. The reason I didn’t have this option was because the Google account I logged into to set up the Google API was a different account than the email I wanted WP SMTP plugin to send email from. Once I created an API authorization from the same gmail account that I want to send from the option to set as Internal was available.

    @fpmtinc Thank you for the update!

    I’m having the same problem as @fpmtinc (I see this screen: https://fpmt.org/smtp.PNG) and I’m logged with the right Google account. Internal is still not available but I did all right. Where could the problem come from?

    I also am logged into the GMail account that WP Mail SMTP needs to send email to and from and the option Application Type is not available, and of course the option “Internal” is not available.

    On the OAuth console screen I have
    – added the url to the site’s Terms, Conditions and Disclaimer page
    – added the site’s URL to the owners property in Search console (while logged into the owner’s GMail account.

    What is all this Google Cloud Migration of Project to Organization about that I’m trying to work through??

    Same here, “Internal Option” is not available. I am guessing “internal option” will be available only for Gsuite user?

    Anyway, if the developer can guide us what to write on the verification screen, we can submit for verification. [Verification Screenshot: http://prntscr.com/mmlxwe ]

    • This reply was modified 1 year, 8 months ago by mr_fanatic.
Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Gmail: email “Submit your app for Restricted Scopes OAuth verification”’ is closed to new replies.