Support » Plugin: WebP Express » gmagick and imagick extension

  • Resolved EckyBrazzz

    (@eckybrazzz)


    gmagick and imagick extension. When I hover on these two in the plugin it says that they are required, but for some reason I can’t get my server (Centos7 with PHP 7.3.5) to activate them both at the same time.

    PHP Warning: Cannot load module 'imagick' because conflicting module 'gmagick' is already loaded in Unknown on line 0

    • This topic was modified 9 months, 1 week ago by EckyBrazzz.
Viewing 4 replies - 1 through 4 (of 4 total)
  • You do NOT need both of them. One extension is absolutely enough to do all the job.

    Plugin Author rosell.dk

    (@roselldk)

    As @kashmiri says: One working conversion method suffices.

    However, there can be a reason to have both. Only imagick and imagemagick can detect quality of jpeg files. gmagick can not do this. So say you have gotten gmagick to work with web, it will be an improvement to get imagick or imagemagick working, for the sake of choosing quality intelligently when converting jpegs to webp.

    I btw. have both imagick and gmagick installed on my local machine (Xubuntu) and also on one of my development servers (Ubuntu). So it is possible (but perhaps not on Centos7)

    • This reply was modified 4 months, 2 weeks ago by rosell.dk.
    • This reply was modified 4 months, 2 weeks ago by rosell.dk.

    Just as an addendum, I ran WP-Cli today and it no longer lists gmagick as a recommended or required PHP extension. Has gmagick support been dropped from WordPress?

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.