WordPress.org

Support

Support » Plugins and Hacks » CM Tooltip Glossary » [Resolved] Glossary Terms NOT working on posts

[Resolved] Glossary Terms NOT working on posts

  • Hello guys,
    thanks for this great plugin. I have a small problem and maybe is something wrong Im doing, I added few terms for the glossary and that looks great but when i go to the post I dont see any links there for the terms. I dont need the tooltip and I have turned that option off. Everything seen to work beautiful exception for the links.

    What can it be?

    thanks and I cant wait for the new update

    http://wordpress.org/extend/plugins/enhanced-tooltipglossary/

Viewing 15 replies - 1 through 15 (of 22 total)
  • Plugin Author CreativeMinds

    @creativemindssolutions

    Do you see the glossary page ? can you send a link to it ?
    and an example for a page which include a term in the glossary that does not show up

    Thanks for the prompt reply CM.
    http://www.ushealthy.com/glossary-terms/

    and here is a post sample that contain both of the terms
    http://www.ushealthy.com/home-remedies/home-remedy-for-acne.html

    please check on remedy #2 and Remedy #3

    thanks

    I am having a similar issue which happened both before and after updating to version 2.0.2.

    I have found the cause of one bug which is when there is a space character following the title of a glossary item. This can be solved going to the edit page for that item and removing any unwanted space following the title.

    The function trim() could be added to the plugin in the next update to force it to remove unwanted spaces before or after a glossary term. This is probably used on the glossary index, but not currently used to check the glossary title against posts/pages containing the term. Should be an easy fix. 🙂

    This solved most of the problems for me, but there are some glossary terms containing special characters such as $, & and ‘, which do not get linked to on a page, but do get linked to on the glossary index.

    I’ve noticed my theme converts this ‘ into the forward tick apostrophe.

    Please see these terms for example: “$100 DOWN PAYMENT PURCHASE”, “MECHANIC’S LIEN”, “MERCHANTS & MECHANIC’S LIEN”, “METES & BOUNDS”

    Here is the glossary index:
    http://dreamloan.pro/glossary/

    Here is a page containing the same list of glossary terms for testing:
    http://dreamloan.pro/glossary-terms-check-hover-items/

    BTW, I’m using WPZoom Prime theme, in case that is the source of the problem. http://www.wpzoom.com/themes/prime/

    Plugin Author CreativeMinds

    @creativemindssolutions

    New version will be released today, that will fix your issues (ampersands, apostrophes, dollar sign).
    It was found out that the way characters are being transformed in the template strongly relies on server’s configuration (charset mostly). In new version, UTF8 will be forced, so it should be OK in all environments.
    Please let us know if that will help after the new version is installed.

    Awesome! Thanks for all the great work.

    Plugin Author CreativeMinds

    @creativemindssolutions

    New Version in Up please update us if this solve the issues

    OK, testing 2.0.3 on this page:
    http://dreamloan.pro/glossary-terms-check-hover-items/

    It has repaired terms with $, but others, such as “BUYER’S AGREEMENT”, “RATE/TERM OR RATE & TERM REFINANCE”, “REALTOR®” and “CC&RS” are still not recognized. Unfortunately, we must include that reserved mark. :/

    If you think this may be caused by a theme issue, any tips on where to repair it?

    For me I still have the same problem as before, I havent notice any changes detecting the terms on the posts thanks

    Plugin Author CreativeMinds

    @creativemindssolutions

    We will work on this Monday, it is related to charset and special symbols, hope to manage fixing this next week

    Thanks CM’s you guys have a nice Mod here and thanks for sharing it for FREE. Cant wait to see a clean version of this plugin.

    Plugin Author CreativeMinds

    @creativemindssolutions

    We released version 2.0.4, we don’t think it solved the issue reported but let us know if u have any change after installation. We will release a new version tomorrow also

    No change here, as expected. Will test 2.0.5 tomorrow. Thank you!

    When It comes to adding the links to the terms used on the glossary to the posts still the same. 🙁
    I download the one tomorrow and see

    thanks guys

    As you can see in this new post is working to perfection. The old posts still the same issue as it didnt fixed them. Should I try deleting the post and reposting it again? or something else i should try?

    thanks Bud

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Resolved] Glossary Terms NOT working on posts’ is closed to new replies.
Skip to toolbar