Support » Plugin: Genie WP Favicon » Gloss on iOS devices

  • Resolved MonkeyKong



    I love that your plugin works, I’ve tried to manually create favicons earlier. They all worked on standard browsers but not on iOS.

    May I make a request? Your plugin makes great favicons that work when you use iOS’s “Add to Home Screen” which creates a link ot the site directly as an app icon on your phone, not in the actual browser.

    However, it also adds the usual “gloss” function, which looks kind of bad. Would it be possible for you to add this functionality?

    It is described on

    If you prefer to add your own effects, be sure to append the -precomposed keyword to the end of the image file name.

    Thank you for a useful plugin.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Prakash Mohankumar


    Your request is fixed with the Genie WP Favicon v0.3

    Please update your plugin check if the fix works fine and let us know.

    Hmm, it’s hard to tell if the gloss function works because I have trouble updating the favicon at all.

    I select a new image, 128×128 .png file, 78 kB, and click on “update favicon”. I get the message “favicon updated successfully” but the current favicon preview still shows the old image, and the favicon has not been updated at all. To make sure I tried with just a red square as image to easily see if it updated, but that is not the case.

    I am using your plugin version 0.3 and WordPress 3.5.1. Do you have any idea what could be wrong? I have tried the exact same thing on two different sites with the same result.

    I deleted the plugin and started fresh with a reinstall. I did not work, sadly.

    Plugin Author Prakash Mohankumar


    Sorry for the trouble, Will update you in this issue soon.

    Plugin Author Prakash Mohankumar



    I have tested in a fresh installation on WordPress and i do not any issue with the updated plugin.

    Please follow the steps in the If it does now work still, Please send us the steps you followed and also the error or warning if you find any on the new installation .

    First of all, thank you for testing.

    Secondly, I still have the same problem. I just setup a completely new WP install on a new domain:

    I followed your install instructions and have record a YouTube video if you want to check if I’ve done anything wrong.

    On the first try I check the box that says “disable gloss” and the favicon is saved. The favicon shows up on my iPad but still with the gloss.

    The other problem still remains: When I try to select another favicon, I get the message that it has updated but that is not the case. As you can see, the old favicon is still shown in the preview. I can’t show you my iPad on screen so you’ll just have to take my word that it doesn’t work like it should.


    Plugin Author Prakash Mohankumar



    Thanks for taking so much effort. I’ll try to figure whats wrong with the code again. And just for an info, in Web pages mostly the Favicon will be cached on your first visit. Even that might be the problem why the updated icon not shown.

    Since I do not own any Apple products, am finding difficulties to test it. Please tweet me @ prakashm88 so that i’ll give you offline code to check in your Apple devices.

    No no, thank YOU! I’m glad I can be of use, though. You may be right about that web browsers cache the favicon on a computer, but with iPhone or iPad my experience is that the favicon is replaced automatically on your home screen after visiting a site with an updated favicon. You don’t even have to save the bookmark anew, it’s totally automatic as soon as you visit the site a second time.

    I’ll tweet you from @monkeykong. If you want me to help out with testing, feel free to email me at

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Gloss on iOS devices’ is closed to new replies.