Support » Plugins » Global Translator – unable to initiate plug-in

  • I’m in no way shape or form HTML or CSS savy or any of that tech stuff, so please be patient with me if the solution to my problem is something simple but I’m just over looking it.

    I tried installing new plug-ins for my site, and I successfully loaded the files for this plugin using my FTP client. I signed into the WP, and when I went to activate the new plugins, the WHOLE site screwed up. You can click on the link to see (at the time of posting this) how it looks. It has the following error for the whole page:

    “Unable to complete Global Translator initialization. Plese make writable and readable the following directory:

    * /srv/www/web4/web/wp-content/plugins/global-translator”

    So I went into the server, and tried deleting the Global Translator, and get the message:

    The following error occurred:

    /web/wp-content/plugins/global-translator could not be deleted. The directory must be empty and you must own write permissions.

    URGH. I don’t know what directory it means since about all I know is how to go to the plug-ins on my server. Maybe I downloaded something malicious and screwed everything up myself?
    I’ve tried searching online for the problem being discussed in any forums but I mostly find people praising this plugin.

    Any help explaining what I did wrong and how to fix would be great.


Viewing 3 replies - 1 through 3 (of 3 total)
  • Nevermind, my webmaster went in and just removed it or something for me.
    I’d still like any help so I can do this myself if it happens again.


    Hi Stevie B,
    I have the same problem with that plugin, and I can’t set a permission higher then 666 in my hosting service. Both Global Translator 1.0.5 and 1.0.6 give me the “Unable to complete Global Translator initialization” error.

    Someone can help us?

    What hosting service do you use? I’ll make a note to avoid them!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Global Translator – unable to initiate plug-in’ is closed to new replies.