Support » Plugins » Global Translator plugin doesn’t work for me

  • I’ve tried to install Global translator on my blog, but I always get a 404 error page when I click on flags. Some details:

    – I tried to turn off all others plugins
    – I don’t use .htaccess, I’m on IIS server
    – I have custom permalinks and I updated options as FAQs say

    Moreover:

    – I can see the flags and their respective URLs correctly match my rewrite rules
    – Plugin does not write any file in cache, even if correctly creates gt-cache directory and its subdirectory. I don’t see any error message referring to file/folder permissions
    – I installed it on another blog of mine (linux server) and there it works!

    Anyone could help me?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Updates:

    Now I know approximately where’s the bug: I tested GT plugin on a new wordpress blog on the same website. It works only if I use standard permalink path (/?p=123); if I try any rewriting rule (index.php/…/..etc.) GT doesn’t work anymore and a 404 error is triggered on any translation trial.

    Such bug should be solved since 1.0.9 version, but I tried 1.2 and 1.0.9.2 obtaining same results.

    Please help me! 🙂

    Updates again!!

    Now I know where’s the bug but I cannot figure why!

    The problem is here:
    add_filter('generate_rewrite_rules', 'gltr_translations_rewrite');

    the function gltr_translations_rewrite doesn’t load (why?) so no rules are added to wordpress rewrite rules. I tried rewrite_rules_array instead of generate_rewrite_rules (which is deprecated for add_filter)

    add_filter('rewrite_rules_array', 'gltr_translations_rewrite');

    but it still doesn’t work.
    What causes such bug? IIS – isapi rewrite? wordpress last version (2.7.1)? bad luck?

    Did you ever solve the problem? I have the same issue. Global Translator works with default links but not other permalinks. The problem came about after transfering DB to new host, server and domain. I have tried uninstalling and reinstalling the plugin as well as deactivating all plugins except global translator with no success.

    Where do i find the code:

    ‘add_filter(‘generate_rewrite_rules’, ‘gltr_translations_rewrite’);’

    Regards,
    Reena

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Global Translator plugin doesn’t work for me’ is closed to new replies.