• Resolved baddon250

    (@baddon250)


    I see you added the fields to add the profiles for indexing. I have a custom user role and the admin panel changes the robots meta from follow to unfollow, but it doesn’t change noindex to index, which is what’s needed to work with google webmaster. There’s a lot of my pages that aren’t being indexed because of this.

    Google wants the code to show up like this.
    <meta name=”robots” content=”index, follow”>

    Currently, it shows up like this.
    <meta name=”robots” content=”noindex, follow”>

    Here’s an example profile.
    https://www.thehandyguy.com/pro/aaa-superior-sliding-door-repair-murrieta-46/

    Also, titles of the pages are not reading the user’s profile name for SEO and I’m not sure how to make them proper.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor Champ Camba

    (@champsupertramp)

    Hi @baddon250

    I just checked the meta, it is now using index,follow. Also, the Profile page is showing the user’s profile name.

    Regards,

    Thread Starter baddon250

    (@baddon250)

    Thanks a bunch for the quick reply, I actually figured out my problem. I clicked on the edit page on the admin taskbar when I was on a user profile page and scrolled down to the Yoast Seo settings, clicked on the advanced setting and saw that the user pages were set to nofollow. This was overriding the settings set in Ultimate Member, so I changed it to follow and everything worked. Hope this helps the next person that has this problem.

    Thread Starter baddon250

    (@baddon250)

    How about the title tag for the page? It doesn’t display the username, just says “user”

    Plugin Contributor Champ Camba

    (@champsupertramp)

    Hi @baddon250

    It shows the Profile name as a Page title on my end.
    https://drive.google.com/file/d/18_fkQgkXVuzyCDhk6yuqz15Ni3HMMYxC/view?usp=sharing

    Please try clearing your browser cache and see if the goes away.

    Regards,

    Plugin Contributor Champ Camba

    (@champsupertramp)

    Hi @baddon250

    ..Please feel free to re-open this thread by changing the Topic Status to ‘Not Resolved’ if any other questions come up and we’d be happy to help. 🙂

    Regards,

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.