Support » Networking WordPress » Giving WordPress Its Own Directory -> Page not found

  • r4ph0u

    (@r4ph0u)



    Hello,
    I will be using the multisite on my wordpress, so first of all, I’ve followed the Giving WordPress Its Own Directory codex tutorial. I’ve used the 2nde method (and I’ve triple checked all steps) but now, my CSS looks broken (the website shows blue links and no style) and I can’t access the admin pannel because “That page can’t be found.”

    How can I deal with it ?

    Thanks

    EDIT : obviously, i forgot to backup the website before doing that

    • This topic was modified 5 months ago by  r4ph0u.

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Hello @r4ph0u,
    Have you tried reversing the “Giving WordPress Its Own Directory” tutorial steps to get back to your original state?

    r4ph0u

    (@r4ph0u)

    Thanks for replying.

    Indeed I tried but as I’ve changed the URI of the installation within the wordpress manager, I can’t change it back because I still can’t access it, and I don’t know how to modify it from files (I’m new to wordpress)

    I also tried to re-upload all wordpress files (except “wp-content/” and “wp-config.php”) but it didn’t resolved my problem.

    Please try the following tutorial in changing WordPress’s url by editing wp-config.php

    Changing The Site URL / Edit wp-config.php

    r4ph0u

    (@r4ph0u)

    Thanks for the link

    Unfortunately, that method didn’t worked for me.
    First of all, I tried the followings, without success :

    define('WP_HOME','http://lelacrosse.cmslauncher.info/AFL');
    define('WP_SITEURL','http://lelacrosse.cmslauncher.info');
    define('WP_HOME','http://lelacrosse.cmslauncher.info/AFL');
    define('WP_SITEURL','http://lelacrosse.cmslauncher.info/AFL');

    Finaly, I moved back the files on the parent folder and used that:

    define('WP_HOME','http://lelacrosse.cmslauncher.info');
    define('WP_SITEURL','http://lelacrosse.cmslauncher.info');

    That way I had access to the login page, but when I click “login”, the page refresh or something and asks me the password again (I’m 800 % sure the password is correct)

    I also tried the second method without success..

    Finally, the Changing the URL directly in the database method worked

    I now have my initial config back

    I’ll tried to move it again, after making a backup.

    Thanks to you !

    No problem, glad I was able to help you today πŸ™‚

    Please mark as resolved if you don’t need anything else πŸ™‚

    r4ph0u

    (@r4ph0u)

    So I tried again with the regular method explained in the codex
    Giving WordPress Its Own Directory

    I have the same problem.
    When I go back into phpMyAdmin, I have the following error:

    phpMyAdmin – Error

    MySQL 5.5.0 or later should be used.

    So it seems that’s where the problem comes from there.
    I changed back the files location and edit the database in order to get my initil config.

    Can you please tell me the steps you are doing to change WPs installation dir?

    r4ph0u

    (@r4ph0u)

    1. Creating the “AFL” folder in the “public_html” folder on my hoster cpanel
    2. In WP Dashboard -> Settings -> General
    2.1. Changing WordPress URL to http://lelacrosse.cmslauncher.info/AFL
    2.2. I let the website URL as it is : http://lelacrosse.cmslauncher.info
    2.3. Saving

    At this step, the css of the website gets broken and prints “page not found”

    3. Moving all files from public_html to AFL
    4. Copying .htaccess and index.php from AFL to public_html
    5. Editing index.php from
    require( dirname( __FILE__ ) . '/wp-blog-header.php' );
    to
    require( dirname( __FILE__ ) . '/AFL/wp-blog-header.php' );

    6. Trying to connect unsuccesfully to http://lelacrosse.cmslauncher.info/AFL/wp-admin

    Have you reversed it now?

    r4ph0u

    (@r4ph0u)

    Yes, I’ve successfuly reversed it directly from the database

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.