WordPress.org

Forums

[resolved] Giving WordPress Its Own Directory (18 posts)

  1. manverine
    Member
    Posted 1 year ago #

    Hello,

    So I have followed everything according to the instructions (http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory). The only problem is that my site doesn't work.

    The login for the new domain works at http://www.crossfitpegasus.ch/cfp/wp-admin and everything is exactly how it should be when I log in. But when I go to view my site http://www.crossfitpegasus.ch it doesn't work. I am hosted by bluehost and a 404 error comes up.

    Where did I go wrong?

    Please help

  2. Colin Young
    Member
    Posted 1 year ago #

    Hey Manverine

    You would probably need to give a lot more detail. If you've followed the steps as they're printed then I'm not sure.

    If you want to go through it step by step when feel free to contact me and we can have a look at it.

    Something to check would be trying to install it in the root of your URL to see if that works. If that works then there is a problem with the instructions, or you've missed a step.

    I wouldn't have thought it would be a name server problem if you can get to the login page.

  3. WPyogi
    Forum Moderator
    Posted 1 year ago #

    @Colin The Puzzle Master -

    feel free to contact me

    I'm going to assume you mean to post back in this thread?

    http://codex.wordpress.org/Forum_Welcome#Helping_Out

  4. Colin Young
    Member
    Posted 1 year ago #

    Where did my other post go?

    I was saying that it would be easier to look at it rather than spend potentially days posting logs/screenshots/details especially since the OP said they've followed the instructions.

    Another pair of eyes is always a good thing

  5. Off topic for a moment.

    Colin? Support stays on the forums and these forums are the other set of eyes. That's how it works here and that's how support is provided.

    It may take 5 minutes or it may take 5 days. But taking support off of the forums is really discouraged. It's something that can be too easily abused.

  6. Colin Young
    Member
    Posted 1 year ago #

    no problem. I appreciate what you guy are saying.

    Back on topic, manverine, I would probably start by making sure that your htaccess and index files are correctly placed and edited.

    Steps 6 to 11 in the codex look as if they could be prone to error (specifically step 7)

  7. manverine
    Member
    Posted 1 year ago #

    I believe that I correctly placed the .htaccess file, but I didn't edit it. And the Index file I'm sure I followed everything. I copied it and edited it to point to the file I had created in public_html where I had moved everything for my wordpress site. Origianlly I tried to do all of this with Filezilla but all the tutorials I found were far to confusing. So I simply put my website into a .zip, and moved it to the new location.

    I just want to know, if I can get into my admin area, what is stopping my website from working? Is it a problem with what I did in my file manager? Or Server? Or WordPress? That would be great if I could know which area to focus on.

  8. bemdesign
    Member
    Posted 1 year ago #

    So you can access the admin backend? That's a good sign. I would check in Settings->General and make sure that the Site URL is correct.

  9. manverine
    Member
    Posted 1 year ago #

    Site URL is crossfitpegasus.ch. But here is the weird thing, I now cannot the WordPress URL or the site URL. That just started to happen. When the codex says, copy index.php and .htaccess to blog address, where is that? I think I may have gone wrong there. Where do I find the blog address, is it in myphpadmin or my file manager?

  10. manverine
    Member
    Posted 1 year ago #

    *cannot change the WordPress URL or site URL.

  11. bemdesign
    Member
    Posted 1 year ago #

    That would mean you would move those two files to the root directory of where you want your WordPress site to "live".

    So let's say you have a server file structure like so:

    --root
    --wordpress

    You would want to move the .htaccess and index.php file outside of the wordpress folder and into the root folder/directory of the server. You would do this using your file manager.

    And then make sure this is reflected in your WordPress Settings->General. So in this case you would have "http://your-domain-name/wordpress" for the WordPress address and "http://your-domain-name" for the site address.

    Make sense?

  12. Colin Young
    Member
    Posted 1 year ago #

    Sorry if I'm being fussy but I think this may have caused a problem (although I could be wrong).

    You have to copy the files, not move them. I assume that means they have to exist in 2 locations. 1 copy of both in your default location and 1 in your custom folder.

  13. esmi
    Forum Moderator
    Posted 1 year ago #

    Correct.

  14. manverine
    Member
    Posted 1 year ago #

    Ok so I'm still at a loss. The file I want to use for my site is called "cfp", and the file where the site originally was, is called "crossfitpegasusch". Now I copied the files and moved them from "crossfitpegasusch" to "cfp" and changed the index.php to point to "cfp". So the originals are still in the original file of the wordpress site. Is there anywhere else that these files need to go? Like I said the admin works perfectly fine, but I always get a 404 error when I try to view the site.

    Also I copied all the other wordpress files as well. Should I delete all the ones in the original folder?

    What would point my server in the right direction to read all the files for my site?

    Thanks so much for all your help. I know this may be frustrating to try an explain to a newbie. I really appreciate it!

  15. Colin Young
    Member
    Posted 1 year ago #

    When you installed WordPress did you

    1. Install it using some sort of script in cPanel?
    2. Install it to the new folder?

    Or, did you install it to the root of your host (probably public_html)? then try to move it to the cfp folder?

  16. manverine
    Member
    Posted 1 year ago #

    I installed it using the user friendly version that bluehost gave. I don't know beyond that, but the file that everything was in for my wordpress site was in public_html.

  17. manverine
    Member
    Posted 1 year ago #

    Okay so I totally misunderstood where to put the .htaccess and index.php. I just put them in public_html and the site works perfectly! Thanks everyone for your help. I am very happy about this.

  18. Colin Young
    Member
    Posted 1 year ago #

    Glad to help. I love getting my teeth into problems like this and more often than not, taking a step back from the problem gives you clarity of vision

Topic Closed

This topic has been closed to new replies.

About this Topic