Giving WordPress its Own Directory (3 posts)

  1. icastano
    Posted 9 years ago #

    I've followed the instructions in this article:


    and I have some problems, the blog appears fine, but the links have this format:


    While the correct link should be:


    I can easily fix it by searching for get_settings('home') in template-functions-links.php and removing the slashes manually, but I have to do that on every update and it usually doesn't fix all the links.

    Is there any other way of solving this problem? Is that a bug or a feature? I've been having this problem since ~wp-1.5.


  2. Don't search/replace because WordPress is not the problem (i.e it works fine for me).

    I suspect you just have funky permalinks on or something. Just use the default ones or turn on pretty permalinks.

  3. icastano
    Posted 9 years ago #

    I'm using the default ones. I've tried the others and I get the same results. For example:


    While this works fine:


    Oh, I just discovered the problem! It's just that the reference to the css file was relative. Making it absolute fixed the problem.

Topic Closed

This topic has been closed to new replies.

About this Topic