Support » Plugins and Hacks » Gives false error about missing libraries

Gives false error about missing libraries

  • Really Simple CAPTCHA 1.7 is causing fatal error on Contact 7 forms. In the Contact 7 forms setting editor of any form, an error box at the top states that the GD and Freetype libraries are missing. Upon checking using phpinfo, I find that this is a false error as they are clearly installed as php mods. If there is some other way they need to be installed, please provide some instruction.

    Dan W


Viewing 3 replies - 1 through 3 (of 3 total)
  • FYI, the form error is the same one several others have listed on this forum:

    Fatal error: Call to undefined function imagettftext() in /home/USER/public_html/wp-content/plugins/really-simple-captcha/really-simple-captcha.php on line 126

    If the others would check the form editor area, perhaps they would find that this plugin also gives the message that the GD and Freetype libraries are missing.

    I know that mine are not missing, however, I am wondering if it’s simply due to me having suhosin and the suphp mod enabled for my php installation, which may cause some scripts to fail. Can anyone verify this?

    I have the same issue. The scenario I had is:

    Running CentOS 5.x (latest version)
    PHP 5.4.28
    I installed Contact Form 7 and the Really Simple Captcha plugins.
    Created my first form with my first captcha
    Received the message that I didn’t have the libraries installed
    Found that I had freetype but did NOT have gd installed
    Installed gd
    Restarted Apache httpd
    Logged back into WordPress blog, went back to my form
    Tried to resave my form
    Received the same error message stating that the libraries are missing

    Not sure what to do now.

    I’m NOW having the same issue, so I had to just deactivate this captcha plugin. IT WAS WORKING BEFORE just fine. NO IDEA what’s going on now. I’m clueless.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Gives false error about missing libraries’ is closed to new replies.