Support » Plugin: GiveWP - Donation Plugin and Fundraising Platform » Give Plugin will not activate

  • Resolved wlepera

    (@wlepera)


    Using Give 2.94 with WordPress 4.9.8

    When I accessed my website’s Dashboard this morning, I was prompted to update several of the installed plugins. I did so, and then reloaded my site’s homepage. All looked fine, and I was able to login as an admin user. When I tried to access the WP Dashboard, I simply got a blank page. I tried a couple of different browsers and clearing cache in between, but nothing worked. Next step was to contact my web hosting provider. They disabled all my installed plugins and got the admin access and Dashboard working again.

    At that point I began enabling the plugins one by one. All enabled successfully, except the Give plugin, which failed with this message:

    Fatal error: Uncaught Error: Call to undefined method WP_Error::has_errors() in /home/jenniefo/public_html/a/wp-content/plugins/give/src/Framework/Database/DB.php:78 Stack trace: #0 /home/jenniefo/public_html/a/wp-content/plugins/give/src/Framework/Database/DB.php(25): Give\Framework\Database\DB::runQueryWithErrorChecking(Object(Closure)) #1 /home/jenniefo/public_html/a/wp-content/plugins/give/src/Revenue/Migrations/CreateRevenueTable.php(53): Give\Framework\Database\DB::delta(‘CREATE TABLE wp…’) #2 /home/jenniefo/public_html/a/wp-content/plugins/give/src/Framework/Migrations/MigrationsRunner.php(86): Give\Revenue\Migrations\CreateRevenueTable->run() #3 [internal function]: Give\Framework\Migrations\MigrationsRunner->run(”) #4 /home/jenniefo/public_html/a/wp-content/plugins/give/src/Helpers/Hooks.php(37): call_user_func_array(Array, Array) #5 /home/jenniefo/public_html/a/wp-includes/class-wp-hook.php(286): Give\Helpers\Hooks::Give\Helpers\{closure}(”) #6 /home/jenniefo/public_html/a/wp-includes/class-wp-hook.php(310): in /home/jenniefo/public_html/a/wp-content/plugins/give/src/Framework/Database/DB.php on line 78

    Unfortunately, I do not know if the Give plugin was one of the updated plugins. The version that’s installed now is 2.9.4.

    Any thoughts on how to fix this? I have no objection to removing and reinstalling the plugin, if that’s what’s necessary, but really don’t want to lose the donation forms and other configuration I have currently setup. Thanks.

    • This topic was modified 1 month, 4 weeks ago by wlepera.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor Ben Meredith

    (@benmeredithgmailcom)

    Hi there! This is a known issue edge case issue related to using GiveWP on a version of WordPress older than 5.1.1. Our team is aware of the issue and will release a new version to patch that issue very soon.

    In the meantime the fix is to update WordPress itself to version 5.2 or newer.

    Here’s where you can follow along on the status of that release: https://feedback.givewp.com/bug-reports/p/givewp-should-be-compatible-with-wordpress-511

    I’m marking this resolved here, but feel free to follow up there. Thanks!

    Thanks for this update. As I am running a pre-Gutenberg WP version 4.9.8, I’m not certain how “painless” an update to the current Gutenberg-enabled version would be. So, I’ll wait for the update to be released. I’m glad your team is putting some urgency on this – this is the time of year where many non-profits do the bulk of their fundraising, and online donations are a significant portion of this. Thank you again.

    I have the same issue ! And we are right in the middle of a donation campaign…
    I would like to update Give plugin because the credit card fields don’t activate anymore when the donation form page loads…
    If you have any other solution I could apply now, it’d be great !

    • This reply was modified 1 month, 3 weeks ago by StinX.
Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.