Support » Plugin: Give - Donation Plugin and Fundraising Platform » Give plugin problems

  • Resolved mrmedoali

    (@mrmedoali)



    Hello 🙂
    Since the last update to the Give plugin, I have been having two main problems:

    1. The Give plugin menu is clicked by default inside text boxes in Elementor, which blocks me from using some of the features of the said text box. Nothing I do or press retracts it.

    2. After clicking the “Donate Now” button and closing the form, the button shifts to the right with the text “Donation amount:” appearing to its left.

    Kindly help me fix these two problems.

    Screenshots:
    1. https://image.ibb.co/idCody/give1.png
    2. https://image.ibb.co/kKgQQd/give2.png

    Thanks in advance!

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Ben Meredith

    (@benmeredithgmailcom)

    Hi @mrmedoali,

    Welcome to the WordPress support forums! Happy to be your first reply ever. 🙂

    Issue number 1 is a known issue with Elementor that has already been patched for the next minor release of Give. You can see the discussion and the resulting patch here: https://github.com/WordImpress/Give/issues/3171 and rest assured that we are working toward getting the other issues on that release handled so that we can push out an update to that.

    For issue number 2, can you provide a bit more context here, so that we are able to help you resolve this? I’m not able to reproduce this behavior. It sounds like what you have is a form embedded using a shortcode with a display style of “button” and you are clicking the button, and then closing the modal before donating, and seeing this behavior.

    I’m happy to help resolve this with you but will need a bit more context. Thanks!

    Thank you for answering.

    Yes, that’s exactly what happens with me in issue number 2 and I can provide the custom CSS I used for the button if that would help.

    mrmedoali

    (@mrmedoali)

    Would you please help me fix this remaining issue?

    Plugin Author Matt Cromwell

    (@webdevmattcrom)

    @mrmedoali — Regarding issue #2 we really would need to see it live in order to be helpful. That’s not an issue we see with Give generally, so most likely it’s unique to your theme or implementation so we’d need to see it live in order to provide any insight.

    Is the form live somewhere that we can access and help further with?

    Plugin Author Matt Cromwell

    (@webdevmattcrom)

    Hi @mrmedoali — following up to see if we can help further and whether you can provide a live link. Let us know, thanks!

    Yes of course and sorry for the delay.

    Here is a link to the page I used to modal in:

    Support Us

    Steps to reproduce the error:
    1. Click on “DONATE NOW”.
    2. Close the modal without donating from the X mark.
    3. The button will shift to the right with the text “Donation amount:” appearing on its left.

    Custom CSS used:

    input[type="submit"].give-submit {
        background: black;
        color: white;
    }
    button[type="button"].give-btn-modal {
        font-size: 30px;
        font-family: "Strait", Sans-serif;
        background: rgba(0,0,0,0.63);
        color: white;
        border-color: white;
        border-width: 3px;
        letter-spacing: 1.1px;
        box-shadow: 0px 0px 10px 0px rgba(0,0,0,0.5);
    }
    
    button[type="button"].give-btn-modal:hover {
        animation-name: elementor-animation-bob-float,elementor-animation-bob;
        animation-duration: .3s,1.5s;
        animation-delay: 0s,.3s;
        animation-timing-function: ease-out, ease-in-out;
        animation-iteration-count: 1, infinite;
        animation-fill-mode: forwards;
        animation-direction: normal,alternate;
        background: white;
        color: black;
        border-color: #6ec1e4;
        border-width: 3px;
        letter-spacing: 1.1px;
        box-shadow: 0px 0px 10px 0px rgba(0,0,0,0.5);
    }

    Hope this will help :).

    • This reply was modified 5 months, 3 weeks ago by  mrmedoali.
    • This reply was modified 5 months, 3 weeks ago by  mrmedoali.
    Plugin Author Matt Cromwell

    (@webdevmattcrom)

    Try adding this:

    .give-hidden {display:none !important;}

    For some reason there is one input that is getting marked as display:inline; after you close the modal. I can’t reproduce anywhere else at the moment, so I hope that workaround helps.

    Thank you very much! This worked like a charm!

    Thanks again for your effort and help 🙂

    Will be sure to report if anything else went wrong.

    Plugin Author Matt Cromwell

    (@webdevmattcrom)

    Glad to hear it!

    If you’re enjoying Give and appreciate our support, we’d love a kind review from you here:
    https://wordpress.org/support/plugin/give/reviews/

    Thanks!

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.