Support » Plugin: Give - Donation Plugin and Fundraising Platform » Give needs to upgrade the database but cannot because AJAX does not appear

  • Resolved LeslieTP

    (@leslietp)


    I am getting the error message:

    Give needs to upgrade the database but cannot because AJAX does not appear accessible. This could be because your website is password protected, in maintenance mode, or has a specific hosting configuration or plugin active that is preventing access.

    Ajax is enabled on my server at SiteGround and none of the other issues apply.

    What do I need to do to make this error message go away?

    When I added the following code to the plugin it broke my site:

    /**
    * Always return true for Give’s AJAX check.
    *
    * If Give is throwing a false positive for admin-ajax accessibility this will bypass the check within give_test_ajax_works.
    *
    * @return bool
    */
    function my_ajax_works_and_im_positive() {
    return true;
    }

    add_filter( ‘give_test_ajax_works’, ‘my_ajax_works_and_im_positive’ );

    Am I supposed to add that to the functions.php file?

    The page I need help with: [log in to see the link]

Viewing 8 replies - 16 through 23 (of 23 total)
  • Plugin Author Matt Cromwell

    (@webdevmattcrom)

    Hi @natdepierre — Give is completely compatible with WordPress 4.9.5, so it’s possible that your WordPress Core files got corrupted somehow and simply resetting them resolved the issue. We have many thousands of users running Give on WP 4.9.5 without issue.

    Hi Matt,

    yersterday I finally update to the latest version of WordPress 4.9.5 and Give is running well now. I like the plugin that’s why I spent time to find a solution.

    Thanks

    Plugin Author Matt Cromwell

    (@webdevmattcrom)

    awesome, great to hear, thanks for the confirmation @natdepierre

    I came here to find a solution. I am running Sucuri and before that Wordfence. No other caching program. I have the latest WP 4.9.4 and this issue is persistent.

    @priya108 have you confirmed with your hosting provider that there is no other caching mechanism in play, like Cloudflare. Having Cloudflare setup was in the end what was the key to my problems. Disabling Cloudflare allowed the update to succeed.

    I’m running into this issue as well. Here’s what I’m seeing: http://p.tri.be/R4jwKL

    I’ve already moved the site to a local environment to attempt to upgrade the DB there, but the steps given here: https://givewp.com/documentation/core/frequent-troubleshooting-issues/handling-database-update-issues/

    Do not align with what I’m seeing. I never get this “run the updater” button, I just get the message above with a link to the help article above. So I’m in a loop that I cannot escape from.

    Can someone please offer some assistance?

    I’ve already tried disabling all plugins except this one. Still get the exact same result. Just as suggested, I’m running local by flywheel in an environment that is identical to what is on my server.

    Plugin Support Ben Meredith

    (@benmeredithgmailcom)

    Hi @projectstart,

    When you visit the Updates page at Donations > Updates do you see a button for restarting the updates there?

    In my experience that “unexpected issue…” message usually indicates that the server is timing out, which can happen if there are a ton of donations. But restarting it two or three times gets it to work.

    If it doesn’t, let us know and we can continue to dig into this.

Viewing 8 replies - 16 through 23 (of 23 total)
  • You must be logged in to reply to this topic.