Support » Plugin: GiveWP - Donation Plugin and Fundraising Platform » Give fills up cron with 32000 tasks

  • Resolved signor.rossi

    (@signorrossi)


    Give fills up my cron with 32000 tasks called “give_validate_license_when_site_migrated”. Execution of other cron tasks fails due to very long execution time of wp_cron.
    This also happens after deleting the plugin and reinstalling it (without deleting my plugin settings/pages).

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Matt Cromwell

    (@webdevmattcrom)

    Our Dev Team is looking into that now. I’ll update you as soon as I have something actionable.

    In the meantime, try installing this plugin to see if you can get the Cron more manageable:
    https://wordpress.org/plugins/wp-crontrol/

    Plugin Author Matt Cromwell

    (@webdevmattcrom)

    Hi there,

    Can you double-check the value of the give_site_address_before_migrate option in your wp_options table? Then check whether it matches your home option.

    There is a current issue where if those two don’t match then the cron will get setup again and again.

    Let me know if those two are different or identical and we’ll go from there. Thanks!

    • This reply was modified 5 years, 12 months ago by Matt Cromwell.
    Thread Starter signor.rossi

    (@signorrossi)

    After having the plugin deinstalled for a while and now reinstalling it the issue does not occur anymore. Maybe a issue with some database-cache by W3TC.

    give_site_address_before_migrate and home_url did match!

    Maybe wp-options -> cron was full with these entries since I the home URL at launching the real page and did not notice it.

    the cron in wp-options looked like below and after emptying the option it filled up again… maybe a cache issue. seemes it has solved itself.

    ‘a:35348:{i:1485278748;a:1:{s:40:”give_validate_license_when_site_migrated”;a:1:{s:32:”40cd750bba9870f18aada2478b24840a”;a:2:{s:8:”schedule”;b:0;s:4:”args”;a:0:{}}}}i:1485278755;a:1:{s:40:”give_validate_license_when_site_migrated”;a:1:{s:32:”40cd750bba9870f18aada2478b24840a”;a:2:{s:8:”schedule”;b:0;s:4:”args”;a:0:{}}}}i:1485278759;a:1:{s:40:”give_validate_license_when_site_migrated”;a:1:{s:32:”40cd750bba9870f18aada2478b24840a”;a:2:{s:8:”schedule”;b:0;s:4:”args”;a:0:{}}}}i:1485278760;a:1:{s:40:”give_validate_license_when_site_migrated”;a:1:{s:32:”40cd750bba9870f18aada2478b24840a”;a:2:{s:8:”schedule”;b:0;s:4:”args”;a:0:{}}}}i:1485278763;a:1:{s:40:”give_validate_license_when_site_migrated”;a:1:{s:32:”40cd750bba9870f18aada2478b24840a”;a:2:{s:8:”schedule”;b:0;s:4:”args”;a:0:{}}}}i:1485278775;a:1:{s:40:”give_validate_license_when_site_migrated”;a:1:{s:32:”40cd750bba9870f18aada2478b24840a”;a:2:{s:8:”schedule”;b:0;s:4:”args”;a:0:{}}}}i:1485278786;a:1:{s:40:”give_validate_license_when_site_migrated”;a:1:{s:3……

    Thread Starter signor.rossi

    (@signorrossi)

    Sorry, I have to inform you that the cron was filled up with these entries again. I will have to uninstall give and empty the cron field in wp_options until a possible fix maybe help.

    Thread Starter signor.rossi

    (@signorrossi)

    Perhaps this task can be fully removed in future versions of give for the non licensed version?

    Thread Starter signor.rossi

    (@signorrossi)

    FIXED!
    This issue was caused by an other plugin
    https://wordpress.org/plugins/wp-cron-control/

    But does the event “give_validate_license_when_site_migrated” really have be called on each page view, as I suspect?

    Plugin Author Matt Cromwell

    (@webdevmattcrom)

    If you want to try to disable it, you can do so by adding this to a Custom Functionality plugin, or your theme’s functions.php:

    remove_action( 'init', 'give_validate_license_when_site_migrated' );
    remove_action( 'admin_init', 'give_validate_license_when_site_migrated' );

    Let me know how that goes.

    Thread Starter signor.rossi

    (@signorrossi)

    Thank you,
    removing ‘give_validate_license_when_site_migrated’ from init in functions.php as described splves the problem.
    It occured, because I have set
    define(‘DISABLE_WP_CRON’, true);
    and use a token for cron with https://wordpress.org/plugins/wp-cron-control/

    Im just triggering wp-cron from a cronjob on the server.

    • This reply was modified 5 years, 12 months ago by signor.rossi.

    We had this same problem after migrating our site to a new host. We changed from the root domain to www at the same time.

    I changed the give_site_address_before_migrate option so that it matched home and the extra cron jobs have stopped being created. So thanks for the tip.

    Plugin Author Matt Cromwell

    (@webdevmattcrom)

    Glad to hear! We’re looking into all of that functionality to tighten it up a bit more, but glad you found this ticket and got it resolved.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Give fills up cron with 32000 tasks’ is closed to new replies.