Support » Plugins » git-svn and WordPress.org plugins

  • I’m a plugin developer. I haven’t updated my .org plugins in over 12 months simply because I moved away from SVN, to GIT. I recently learned about git-svn, and realized I may be able to update and support these plugins again.

    I was able to setup and commit to the master branch, but as soon as I goto “git-svn tag” I get authentication issues. Its letting me commit, so clearly my “authentication” is correct.

    I am following this tutorial specifically:
    http://jeremypry.com/wordpress-plugin-development-with-github/

    I’d love to get these plugins updated, and audit them, so I’m really hoping somebody can help me.

Viewing 6 replies - 1 through 6 (of 6 total)
  • CLI Output

    Seths-MacBook-Pro:sm-sticky-clicky-star sethcarstens$ git commit -m 'rev4'
    [master da1c5a1] rev4
     1 file changed, 1 insertion(+), 1 deletion(-)
    Seths-MacBook-Pro:sm-sticky-clicky-star sethcarstens$ git svn dcommit
    Committing to http://plugins.svn.wordpress.org/sm-sticky-clicky-star/trunk ...
    Authentication realm: <http://plugins.svn.wordpress.org:80> Use your WordPress.org login
    Password for 'sethcarstens':
            M       readme.txt
    Committed r1207275
            M       readme.txt
    r1207275 = a97b4db3bdef5b13c334ee89f1de0a06df7f3e36 (refs/remotes/origin/trunk)
    No changes between da1c5a1e2fb6abf6736c73ec5dfec4dc6ece195a and refs/remotes/origin/trunk
    Resetting to the latest refs/remotes/origin/trunk
    Seths-MacBook-Pro:sm-sticky-clicky-star sethcarstens$ git svn tag 1.1.1
    Copying http://plugins.svn.wordpress.org/sm-sticky-clicky-star/trunk at r1207275 to http://plugins.svn.wordpress.org/sm-sticky-clicky-star/tags/1.1.1...
    Authorization failed: POST of '/!svn/me': authorization failed: Could not authenticate to server: rejected Basic challenge (http://plugins.svn.wordpress.org) at /usr/local/Cellar/git/2.2.2/libexec/git-core/git-svn line 1189.

    Moderator Stephen Edgar

    (@netweb)

    bbPress Team

    Seth,

    I’ve got a couple of things to try, I personally have never used git svn so I couldn’t tell you if this will work or won’t work 😉

    The main difference I see that seems related is in the article you link to the git svn clone instructions do not include tags, so maybe that’s related:

    git svn clone -t tags -b branches -T trunk -r387893

    I snagged the above from:
    http://teleogistic.net/2012/09/16/using-git-locally-for-a-subversion-based-project-like-buddypress/

    A couple of older articles the above is based on:
    http://teleogistic.net/2011/05/23/revisiting-git-github-and-the-wordpress-org-plugin-repository/
    http://teleogistic.net/2010/09/10/using-github-with-wordpress-org-plugin-svn/

    Another issue though I don’t think it should cause an issue is to use HTTPS for SVN repo:

    https://plugins.svn.wordpress.org/sm-sticky-clicky-star/trunk

    Meitar

    (@meitar)

    I’m having the exact same problem described in the original post, above, and what confuses me is that creating tags in this exact way worked without issue several months ago, when I last did it.

    My terminal output is:

    Authorization failed: POST of '/!svn/me': authorization failed: Could not authenticate to server: rejected Basic challenge (https://plugins.svn.wordpress.org) at /Applications/Xcode.app/Contents/Developer/usr/libexec/git-core/git-svn line 1217.
    

    I also found similar complaints about this issue here, here, and here, but none have a solution. 🙁

    I’d very much like to see this working again. git-svn is a key part of my workflow for supporting my many WordPress plugins.

    Any updates on this? i have the same problem with git version 2.5.4 and git-svn. It’s very annoying…

    This issue has recently been plaguing me as well. I found I was able to workaround the issue by using the svn command to create the tag directly:

    svn cp https://plugins.svn.wordpress.org/PLUGIN_NAME/trunk https://plugins.svn.wordpress.org/PLUGIN_NAME/tags/TAG_NUMBER

    I can’t get tagging to work either (and it worked for me a couple months ago). Other people are having this issue here: https://stackoverflow.com/questions/34623108/git-svn-branch-results-in-authentication-failed

    What a hassle it is still having to use SVN…

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘git-svn and WordPress.org plugins’ is closed to new replies.